7

Following problems with the GNU gcc compiler installed through brew (messages about missing libraries that suddenly started appearing) I had to reinstall Xcode 13.4.1 yesterday.

This morning I’m now seeing several updates for Command Line Tools, for other versions of Xcode:

xcode updates

Why is this showing? And how do I dismiss those? gcc is now working fine so I don’t want to mess anything up!

4
  • 2
    Click More Info… & download only the latest one. After install reboot & check again. Report back.
    – Tetsujin
    Jun 9, 2022 at 11:08
  • @tetsujin it worked! how can I mark your comment as an answer? (new to posting on SE)
    – tb87
    Jun 9, 2022 at 17:02
  • I can put it in as an answer so you can mark ti accepted. It was a bit of a guess, that the system would be smart enough to forget the out of date ones once the 'new' update was applid, otherwise I'd have put it straight in as an answer. Glad it worked for you :)
    – Tetsujin
    Jun 9, 2022 at 17:44
  • 1
    well it was a logical suggestion, and it worked ; i think it qualifies as an answer ;-)
    – tb87
    Jun 9, 2022 at 17:45

1 Answer 1

6

The system is likely to be able to shake itself out once the newest update is applied…

Click 'More Info…' set it to do only the latest update, then afterwards reboot & check again. It ought to have cleared the backlog.

1
  • 2
    this worked ; all the other updates disappeared after the reboot, thanks!
    – tb87
    Jun 9, 2022 at 17:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .