Ever since I installed osx and xcode on my new macbook (about a year ago) I got this weirdest problem I can't get rid of. Anytime I press Esc key in xcode, one character gets printed. I can't copy paste it here (it won't paste anything), but it looks like upside-down question mark. When I paste it to the Pages app, it looks like ordinary exclamation mark, probably because of different encoding or something.

This is very annoying, how can I get rid of it? I sure hope it is not a desirable feature. Reinstalling xcode or upgrading from 4.2 to 4.3 didn't help, upgrading osx from 1.6 to 1.7 didn't help either. I would prefer to avoid reinstalling of osx if possible

  • Can you paste it into the search of the Character Palette and tell us what comes up?
    – Tuesday
    Mar 18, 2012 at 14:11
  • I can't paste it there either, looks like it is one hell of a mystery character :)
    – Lope
    Mar 18, 2012 at 14:49
  • Very weird. What shows up when you display the clipboard in Finder?
    – Tuesday
    Mar 18, 2012 at 14:51
  • (I see the problem's been solved, but I still wonder what the character is! :D)
    – Tuesday
    Mar 18, 2012 at 14:52
  • It is empty, as if nothing was copied. I never knew I would learn so many new (basic) things about osx through this question (show clipboard and character palette), thanks for that :)
    – Lope
    Mar 18, 2012 at 14:54

3 Answers 3


A quick google shows this

Take a look at your key binding setting and make sure that ESC is not binded

  • Thanks for pointing that out. I feel like stupid again, because I was googling this many times before and couldn't find any info while you could do that in matter of seconds :/ Weird think is that ESC was not binded but it looks like it should have been. I bound it to "Cancelation" and everything works now. Thanks a lot!
    – Lope
    Mar 18, 2012 at 14:44
  • @Lope When you know what terms to search for, everything is easy to find. We are all librarians on the internet :) Mar 17, 2019 at 9:45

Goto Preferences, type "cancel" in filter text box, double click the key field and reassign by pressing the escape key. Problem solved.

All the credits and thanks to you revolver and Lope.


Try reverting all Xcode settings to their original state using

defaults delete com.apple.dt.Xcode

in the Terminal

  • What does this do, how does it solve the problem described in the question? And which side-effects does it have?
    – nohillside
    Mar 17, 2019 at 9:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .