2

For example, touch Test would normally create a Test file without an extension that should have the usual plain paper white icon. Now it's always set to a blue folder icon. The system "knows" it's not a folder since it's opening it in TextEdit and Open with: is set to TextEdit.

touch Test or echo "test" > Test both create files with the bad icon.

I also tried creating a new text file with TextEdit; kept the Untitled.txt, then removed the extension leaving only Untitled. The icon jumped immediately to a folder icon.

I tried many things from restarting the system to clearing the iconservices, and the iconcache. I also tried Killing the Dock and Finder, rebuilding the LaunchServices database, and restarting again. I just can't get the icon associated with files without extension to go back to the basic plain paper white one.

Makefile

Any idea on how I can get the default plain paper white icon back? Thx

Complementary info: The extension is not hidden with Hide extension, there's simply no extension like with Makefiles, etc.

mdls -name kMDItemContentType -name kMDItemContentTypeTree -name kMDItemKind Makefile

kMDItemContentType     = "public.make-source"
kMDItemContentTypeTree = (
    "public.make-source",
    "public.script",
    "public.source-code",
    "public.plain-text",
    "public.text",
    "public.data",
    "public.item",
    "public.content"
)
kMDItemKind            = "Makefile"

System Info: MacBook Pro M1, macOS Monterey 12.4

More things I tried:

  • qlmanage -r cache && qlmanage -r followed by a killall Finder didn't help
  • Disabled every QuickLook extension and reran the above command
  • Stopped BlueHarvest to avoid .DS_Store files being removed
  • Tried with a Guest User account
  • Deleted ~/Library/Caches/com.apple.finder folder and restarted
  • Ran the full list of OnyX Maintenance tasks (restart included)
  • Restarted in Safe Mode but the problem persists even in safe mode.

Update regarding the LaunchServices database:

I had already tried running the full OnyX maintenance suite and repeated that with the LaunchServices database rebuilding but, as an extra precaution, I also reran the following commands mentioned in several articles on eclecticlight.co and elsewhere with no results:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -v -all u,s,l

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

sudo /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -seed -lint -r -f -v -dump -domain local -domain system -domain user -domain network

Followed by killall Dock and a restart but the problem persists.

1

1 Answer 1

1

What shows up when you select the erroneous icon and hit the space bar? Does it preview a folder icon?

If so, then perhaps you could try qlmanage -r in Terminal, which causes the QuickLook daemon to be restarted and reset. I've noticed that QuickLook, ostensibly for viewing previews, has some influence over icon presentation, as well.

11
  • Thank you for trying to help. That was the first thing I did. I forgot to mention it: qlmanage -r cache && qlmanage -r followed by a killall Finder but it didn't help. QuickLook indeed previews a Folder icon while showing an Open with TextEdit in the upper righ corner. Very disturbing.
    – CollinWoo
    Commented Jun 6, 2022 at 18:42
  • The only thing that gets the icon to change, beyond adding an extension, is a chmod +x Untitled which changes the icon to the dark exec one. But I'm not going to set every file to executable just to get rid of the folder icon.
    – CollinWoo
    Commented Jun 6, 2022 at 18:50
  • I just tried with a Guest User account and the problem persists.
    – CollinWoo
    Commented Jun 6, 2022 at 19:14
  • Is the QuickLook process even running? What does ps aux | fgrep QuickLook tell you? I see eight processes running, at least two of which have PIDs under 1,000, which means they were probably started as part of the boot sequence. Commented Jun 7, 2022 at 2:34
  • ps aux | fgrep QuickLook yields the same result on my machine.
    – CollinWoo
    Commented Jun 7, 2022 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .