0

Normally, I should receive an SMS notification from my carrier about any missed calls if my iPhone or the network is offline. I don't receive them on my personal iPhone, but I receive them on my business iPhone. (Same carrier.)

I spoke with my carrier and they told me that this service is active for my number on their side so there is a setting in my phone which overwrites it. But they don't know where can I set this up.

I Googled a lot about it, but can't find the solution.

Can anybody point me in the right direction to find where this setting is?

Model: iPhone 8 iOs: 15.4.1

6
  • Did you maybe block the number these SMS are sent from? Or do you need to tap on the back arrow at top left within Messages to select messages from unkown senders?
    – nohillside
    May 27, 2022 at 13:48
  • I checked: I have no blocked contacts. Also, I have no back arrow for unknown senders. (I suppose then that this feature is turned off.)
    – SiGe
    May 27, 2022 at 13:53
  • Check to see if Messages settings has "Filter Unkown Senders' enabled. It could be blocking that number, in which case you can simply add it to your contacts. Also, Messages can sort into Known and Unknown Senders, and you could be viewing Known only
    – cmason
    May 27, 2022 at 14:43
  • "Filter Unkown Senders' is disabled. Also, I receive a bunch of messages from unknown senders, so I think the filter is not the case.
    – SiGe
    May 27, 2022 at 14:53
  • Which carrier? Did you check your account settings on the carrier’s website?
    – JBallin
    May 27, 2022 at 23:37

1 Answer 1

1

The solution was Settings > General > Transfer or Reset iPhone > Reset > Reset Network Settings.

(Kindly be helped by Apple Support.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .