1

Last night I updated macOS and suddenly can no longer switch to Persian by pressing the fn (globe) key. It still works for English and Danish but Persian doesn't even show up in the language pop up.

I used to be able to switch between all of my available keyboards by just pressing that button multiple times until the language of my choice was highlighted. Now it only shows English and Danish. Persian is gone!!!

Persian is still visible in the languages list on the top bar. I tried removing it and adding it again but to no avail.

How can I bring that functionality back?

enter image description here

enter image description here

enter image description here

1 Answer 1

0

I was able to fix it but I think it's a bug.

Fix was to enable Select the previous input source option in Keyboard shortcut settings then using the shortcut (normally it's control + space)

The language switcher pop up was shown and this time it actually included the missing keyboard (Persian). Now even using the fn (globe) key, It shows properly.

After that I disabled the keyboard shortcut again and the pop up kept working as intended.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .