3

Problem:

Since updating to macOS 12.4, I have been seeing issues with Safari 15.5. Problem sites load just fine in Firefox (I don't use Chrome or Edge). Searches haven't revealed this as a common problem. None of these issues was present under 12.3

Tried to no effect:

  • cold rebooted.
  • disabled all plugins and extensions.
  • launched Safari in safe mode.
  • emptied caches.

Not Tried:

  • deleting plist files.
  • booting MBP in safe mode.

macOS: 12.4
Safari: 15.5
MBP 2020 Core i5, 8GB

Update 1:

In response to comment from @jaume:

  • Javascript is enabled (and has been consistently throughout this issue).
  • Block all cookies is unchecked (and has been consistently throughout this issue).

Update 2:

In response to comment from @Ezekiel:

  • Hide IP addresses is checked.

Update 3:

While not related to Safari (and therefore OT to an extent) I can confirm that this issue is also present in Mail.app. Remote content may be blocked if the Hide IP Address setting is enabled in Mail. As far as I know, this is also related to macOS 12.4 and (in hindsight) probably less to do with Safari.app and more to do with WebKit or a related codebase.

Potential Solution:

  • Unchecking Hide IP addresses appears to have solved the issue.
7
  • 1
    Have you disabled Javascript in Safari Preferences > Security? If you have, enable it again and report back (many websites require Javascript). Have you selected "Block all cookies" in Safari Preferences > Privacy? If you have, enable it again and report back (some websites won't render correctly if all cookies are blocked). Could you add an example of a website that doesn't load properly for each of the issues you mention?
    – jaume
    May 23 at 9:16
  • 1
    @jaume Thanks for taking the time to respond. More info added to OP.
    – DaveL17
    May 23 at 13:41
  • 2
    Do you have "Hide IP Addresses" enabled in Safari Preferences > Privacy?
    – Ezekiel
    May 23 at 13:52
  • 1
    @Ezekiel Thanks for taking the time to respond. Disabling "Hide IP Addresses" appears to have solved the issue. I will leave it unchecked and will monitor. Will report back with results. Please add as an answer and I will accept that if result continues to work. Cheers!
    – DaveL17
    May 23 at 14:21
  • 2
    "Hide IP Addresses" does appear to be the cause. Disabling the setting solves the issues above. Re-enabling causes the issues to re-appear (with the exception of the issues with the unnamed phpbb site which continues to work). Seems that something around this setting changed from 12.3 to 12.4 that's done it.
    – DaveL17
    May 23 at 14:41

1 Answer 1

3

Sometimes this happens due to iCloud Private Relay. You can disable this by switching off “Hide IP Addresses” in Safari Privacy Preferences.

Hopefully this feature becomes more stable in the future.

1
  • Hi! Turning it off in Safari indeed helped a bit. However, I still get these issues system-wide and I don't have Private Relay (I also found similar setting in wifi options and turned it off). Any idea if there is some other option that I need to turn off or that might be causing this? At this point I cannot update or install any apps because App Store just times-out on everything.
    – daemontus
    Jun 13 at 12:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .