23

I repeatedly see that the Dock is in auto-hide mode. So, I go to settings and disable auto-hide. Yet soon enough, auto-hide returns.

How can I keep this setting from re-enabling itself?

enter image description here

(macOS Monterey 12.3.1)

7
  • 3
    If you have (even inadvertently) used the keyboard shortcut option+command+D it turns on (or off) this setting.
    – bjbk
    May 22, 2022 at 12:37
  • 2
    Full screen mode also hides the dock. apple.stackexchange.com/questions/131854/… (If you can add a little more context to your question, such as when do you notice the change? Moving between apps or spaces? etc) Cheers!
    – bjbk
    May 22, 2022 at 12:44
  • 1
    @bjbk Good idea? I doubt that I have used it repeatedly, but if this problem recurs I can use that to disable the hiding
    – Joshua Fox
    May 22, 2022 at 13:04
  • @bjbk If Full Screen Mode were the cause, the configuration setting wouldn't keep reverting to "enabled". I notice that it is re-enabled occasionally, every few hours during the working day
    – Joshua Fox
    May 22, 2022 at 13:05
  • Yeah, I thought of that after posting the comment, but left it there anyway. Hope you get to the source of the issue. Cheers
    – bjbk
    May 22, 2022 at 13:41

2 Answers 2

17

@bjbk's comment to use option+command+D fixed it for me.

If you have (even inadvertently) used the keyboard shortcut option+command+D it turns on (or off) this setting.

Disable keyboard shortcut

You can disable the keyboard shortcut by opening System Settings and searching for "Keyboard shortcuts". Uncheck "Turn Dock hiding on/off".

Keyboard shortcut setting

1
  • 1
    I think that's how it was getting flipped for me--I have that custom-shortcut in my Windows VM Visual Studio and the mac picks it up. And I just tested window vs. coherence (Parallels) and the mac picks it up keystroke even when parallels VM has focus. Good to know. Dec 5, 2022 at 12:17
1

Right-click the tiny dividing line in the dock, and you will see Turn Hiding On/Off as seen below:

macos dock autohide

From the same dock context menu you can access the corresponding MacOS Settings page via Dock Settings...

And now the important part: if you have a dual monitor setup 🖥️ 🖥️, AND you disabled the option Displays have separate Spaces then you will have the scenario described in the original question where dock hiding seems to turn itself on out of the blue. When using multiple displays you must make sure that Displays have separate Spaces is set to ON (on Ventura the option is the last one in the Dock Settings prefs pane which can be opened from the context menu).

displays have separate spaces must be ON for dual monitor setups

To get the dock context menu hover above the tiny line in the dock until the cursor turns into resize mode ↔️, and then right-click (this area is also used to click+drag to adjust the size of the dock):

dock resize area

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .