2

A while ago, I accidentally allowed WhatsApp Web (web.whatsapp.com) to send desktop notifications. I tried to revoke that permission via the Preferences (as also described in this answer):

enter image description here

but to no avail:

enter image description here

What can I do, other than disabling notifications for Safari in the System Preferences, which I don't want (I have other websites I might need them for)?

This happens on a 2020 MacBook Pro (M1, 13") running macOS 12.3.1, and Safari 15.4

5
  • 1
    Can you just select on the "web.whatsapp.com" line and click the remove button below?
    – AVelj
    May 22, 2022 at 5:03
  • @AVelj yes - not sure how I missed that, I guess it's less discoverable than the dropdown and it ... doesn't really make sense to have two of these similar options? Thanks anyway!
    – Glorfindel
    May 22, 2022 at 17:21
  • no stress! I'm not sure why it kept sending you notifications when you disabled it in Safari's website settings, but all I can think of is that you didn't restart Safari/macOS after disabling notifications for the website, or the relevant plist file hadn't been recompiled after you changed the notification setting for the website at the time. I can't seem to find the relevant plist file on my end (probably because I have not allowed notifications for individual websites), but I suspect that's where it probably went wrong. It's a simple fix generally with erroneous plist files :)
    – AVelj
    May 23, 2022 at 1:18
  • P.S. If you found my original comment above useful, you can upvote it, which gives me some brownie points. I hope you have a great day! :)
    – AVelj
    May 23, 2022 at 1:20
  • 1
    @AVelj I can upvote your comment, but that doesn't give reputation points (it only helps for the Pundit badge). I can't accept my own answer yet; because it's a self-answer, that can only be done 48 hours after posting the question.
    – Glorfindel
    May 23, 2022 at 6:36

1 Answer 1

3

As user @AVelj mentioned, it's possible to select the row and click the Remove button at the bottom:

enter image description here

That did the trick: when I reload the page, I see a reminder of WhatsApp to enable notifications, which is as expected:

enter image description here

1
  • Thanks for the acknowledgement. You should mark your question as answered now :)
    – AVelj
    May 23, 2022 at 1:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .