5

I set this to 2022 since there is a historical nature to this issue. I cannot seem to find any specific articles that seem reasonable. The problem is with using an external monitor with the MacBook Pro (16-inch, 2019). A few months ago I switched from an old Apple display to a newer (but not super new) LG 4k monitor -- the one they sold in the Apple store several years ago. I had zero issues with kernel_task before, and starting having the issue with the new monitor. I was in-between housing for a few months before starting to use the new monitor and working only with the laptop with no external monitor and did not have the issue. Unplugging the monitor now also resolves the issue.

Findings:

  1. Temperatures do not necessarily reach high levels when the issue is occurring. Running Macs Fan Control, I see that the temps rarely go above 70C -- in fact they hover around the same temp generally speaking as when not having the issue. I have seen the temperature go high on occasion, but this was also connected with the separate ManagedClient process (which also runs away on occasion for no apparent reason). There isn't really much a reason for kernel_task to start throttling, unless the temperature sensors are not working properly or something.
  2. Zoom app is the deathstrike. Running Zoom with video on will cause the issue very quickly. A Zoom session with outgoing video and one or more incoming videos is a killer. Turning off outbound video and asking participants to turn off theirs helps.
  3. Similarly, running video apps in the browser seem to cause the issue as well.

Red herrings: There is an enormous body of proposed/supposed fixes for this issue. Here are ones that did not work for me.

  1. Reset SMC or NVRAM. On the surface this seems to work. Yay! Unfortunately, when having the issue, often times restarting the machine seems to help. Resetting SMC or NVRAM involves restarting the machine one or more times.
  2. Connecting the charging of the Mac to the right side. There are many references to plugging in the computer on the right side instead of the left. If this is to alleviate high temperature issues, this would sort of make sense based on the argument that this is causing severe overheating. IMO this is kind of a separate Mac issue. If it works for you, that is great. It isn't my issue. It also kind of sucks from a desk setup perspective if it means that you end up having to put your monitor on the other side of the computer. Mine is connected always on the right side so this did not help me.
  3. Cleaning out dust and applying thermal paste. This could be a resolution also to high temperature issues. If you are inclined to crack your machine open to do this, have at it. I am sure there is some dust in my machine, but as I mentioned above, this is not so much a temperature issue that I can tell. Also, if you need to apply more thermal paste after less than 2 years of use, there are other issues to discuss.
  4. Running hardware check in recovery mode. Did this. Machine is reported to be perfectly healthy.
  5. Running Macs Fan Control. Again, your mileage may vary. For me, it does help a little bit, but does not prevent the issue from occurring. It is sort of like urinating on a bonfire -- it does do something, but ultimately isn't powerful enough a solution.

Semi-practical solutions: Let's get back to the 2 things that seem to be "factual"(?). The external monitor seems to be the culprit, insofar as things that the user can do to cause the issue to occur, and things that drive the monitor harder also seem to aggravate the issue. How can we address these?

  1. Zoom settings for emergency fixes (patch, not solution). See https://support.zoom.us/hc/en-us/articles/4409500570381-Stopping-all-incoming-video-in-a-meeting-or-webinar. This allows you to turn off incoming video should you need to in a pinch. This coupled with turning off your own outbound video can help quite a bit.
  2. I have also seen references to turning off hardware acceleration on chrome and other browsers for video playback. I'm not really sure if this does anything to be honest, but I can't say for sure that it does nothing. It is, however, video display and hardware related, so it sounds maybe reasonable(?).
  3. Changing the resolution used on the external display. I can say for certain that this has worked, at least to the point of making my machine usable. In order to do this, you must go to System Preferences, Displays. Click Display Settings, and while holding down Option, click "Scaled" under Resolution. Then click the "Show all resolutions" checkbox. Find the current resolution your monitor is set to, and choose the same one that says "(low resolution)" to the right of the dimensions. First of all, this sucks, admittedly. It makes your monitor slightly blurry by comparison to what you were running it at. The upside I've found, however, is that I can even join Zoom sessions with multiple people on video without my computer coming to a complete crawl. Since changing this setting I have had the kernel_task issue maybe once or twice in 2 or 3 days and it subsides fairly quickly on its own. Before I was having the issue at least once an hour and had to restart my computer many times a day.

So, my question is -- has anyone recently found a better solution than Semi-practical solution #3 (i.e. in 2022)? I am in the middle of a project at work, and my work somehow determined that the motherboard needs to be replaced, which is impossible for me to accommodate due to time constraints at the moment. Has anyone received any word from Apple indicating that this is a known software or hardware issue that they have a fix in the works for? In all the discussions.apple.com posts I have seen, the Apple rep restates the OP's issue as if it is a completely unknown issue.

7
  • Do you have the i7 or i9 CPU? Either way they are beasts - not sure you can fan or cool your way out of high load or even disable the heat generating Radeon GPU and rely on the integrated one…
    – bmike
    May 21 at 1:33
  • 2.4 GHz 8-Core Intel Core i9 with the AMD Radeon Pro 5300M 4 GB. It seems as though like there is just something just wrong with the way the hardware or software (or both) is handling the external monitor requirements. There seem to be other folks online who seem to indicate this was due to a particular update, though I wouldn't claim to be able to confirm that. To be honest, one reason I posted this was to give light to the display resolution change "solution", which I happened on somewhere but cannot find reference to again.
    – intafon
    May 21 at 4:25
  • Yeah - that combination is easy to run into the ground, thermally. To help others, you might put the “solution” in a neat answer and accept it. If someone has a better answer, they tend to add theirs, too and you can select theirs later if it is more to your liking than a workaround.
    – bmike
    May 21 at 12:00
  • Ah, good point.
    – intafon
    May 22 at 1:15
  • I have the same issue. It seems to have only started in the last month which would suggest there has been an update with something (Zoom?) that has caused it. Jul 19 at 10:40

3 Answers 3

1

Just to recap from above and call out a potential solution for some:

Changing the resolution used on the external display does seem to work, at least to the point of making my machine usable. To do this, you can:

  1. Go to the Systems Preferences and select "Displays"
  2. Click "Display Settings" (at least in Monterey).
  3. While holding down the Option key, click "Scaled" under Resolution.
  4. Click the "Show all resolutions" checkbox.
  5. Find the current resolution to which your monitor is set, and choose the same resolution from the list that has "(low resolution)" in the name.

This will make your monitor seem slightly blurry by comparison to what you were running it at. The upside I've found, however, is that I can even join Zoom sessions with multiple people on video without my computer coming to a complete crawl. Since changing this setting I have had the kernel_task issue maybe once or twice in 2 or 3 days and it subsides fairly quickly on its own. Before I was having the issue at least once an hour and had to restart my computer many times a day.

For a further emergency fix, in case you don't want to do the above, or if you end up still having an issue running Zoom sessions, see https://support.zoom.us/hc/en-us/articles/4409500570381-Stopping-all-incoming-video-in-a-meeting-or-webinar. This allows you to turn off incoming video should you need to in a pinch. This coupled with turning off your own outbound video can also help quite a bit.

1

Adding my own experience as a record. I recently started using my 2019 MBP16' (10.15.7 Catalina, 8-core i9, 2.4GHz, 32GB ram, 5500M 8GB GPU) with a (rather old) external monitor at 1080p resolution (not that demanding – at least I thought). As soon as I plugged in the monitor, kernel_task would fire up and slow down the CPU to 800 MHz. Tried everything in the post (NVRAM reset, switching side for the supply, pluggling the supply directly in the usb-C hub I'm using), nothing worked.

After noticing that whenever this occurred the 5500M GPU showed no sign of activity, I tried forcing the usage of the Radeon GPU at all times by disabling the automatic graphic switching (System Preferences > Battery or Energy Saver). kernel_task disappeared in a matter of seconds, all temperatures dropped, fans silent and CPU speed back to normal. Evidently there was some issue in the automatic switching which actually didn't switch at all – remaining stuck in trying to use the internal Intel UHD630 which clearly barely handles the MBP monitor itself. Hope this helps.

4
  • How did you find out the speed of the CPU? I am experiencing this issue too. Same MBP, same setup, only Big Sur here. At first when I got the comp I didn't experience this issue. Then started noticing it randomly. And in the last days, specially today it's been a nightmare. No wonder, today we are hitting one of the highest temperatures in the last years. Unplugging the monitor seems to "fix". So, joining your pain guys..
    – lubumbax
    Jul 19 at 16:23
  • FYI, I am using gfxCardStatus to dynamically/manually switch the GPU. Currently it is in "Dynamic" mode, which at the moment shows the "AMD Radeon Pro 5300M" in use. So I am not being as lucky as you in this case. Actually, gfxCardStatus doesn't let me switch from "discrete" to "integrated graphics mode" while the monitor is plugged in.
    – lubumbax
    Jul 19 at 16:39
  • I’m using iStat Menus to check the activity of CPU and GPU. Also for me the issue popped up recently. I used to have even two external monitors at higher resolutions and the MBP wouldn’t bat an eye.
    – jackphen
    Jul 19 at 22:09
  • hehe, yeh, the outside and resulting higher inside temperatures do likely play an additional role. I have a sneaky suspicion that it is an issue that somehow got introduced in a software update somewhere and will be or already has been fixed silently. jackphen -- I never saw a reference to your solution in any searches I did. Will have to try it out if I run into it again. I had my work sent me a different monitor (since I was using a personal one) and since then the issue has not really reared its head... (fingers crossed)
    – intafon
    Jul 26 at 12:10
0

In my case it helped to open the MBP(2018,15-inch) and clean the fans. I have 2 LG 5k displays connected and as soon as a Zoom or Microsoft Teams conference started, the temperature was rising although fans were running on max. This resulted finally in the kernel_task hogging > 500%. Buy a pentalobe P5 screwdriver and follow these instructions https://www.ifixit.com/Guide/How+to+clean+your+MacBooks+fan+and+prevent+overheating!/144643

New contributor
Stephan is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • Thx for the hint but how does your answer the original question which is about a external monitor causing very high CPU utilization rates?
    – Alper
    4 hours ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .