4

I upgraded to 12.4, I had been using Universal Control between two MacBook Pros (Intel ones that are still new enough to support Universal Control) and it had been working great. But after upgrading to 12.4 Universal Control is not working any more.

I read a bit about how to try to fix this in other forums. It seems like the thing to do is to turn it off (uncheck the 3 boxes in the Display Preferences) restart the computer(s) and then turn Universal Control back on again.

That changed the checkboxes but didn’t allow the mouse pointer to cross systems.

There's also another strange symptom. On one of the laptops the third check box (the one about automatically reconnecting) won't check. I can't click on it at all. It does not look "disabled" (greyed out) but it won't check. I suspect that laptop is the one with the "issue" and the other one is probably working fine (it takes 2 to tango though).

One more odd thing. Both Macs have external monitors hooked up. On the Mac that was acting strange I unplugged it from it's Thunderbolt hub (how it is connected to the monitors) and now I could check the third box. Universal Control still didn't work though.

Oh yeah, for what it's worth I tried turning Universal Control off on both Macs (and restarting both of them) too.

I say that because most of the stuff you read about "Universal Control" is about connecting a Mac to an iPad. But clearly it's supposed to support 2 Macs.

Universal Control Settings

Since this is a new feature on a new release are people finding a need to take cleanup steps or have solved this yet?

3

4 Answers 4

0

I would go straight to Apple Support and not try to list all the things. Start with fresh perspective and let the, direct what to do and in what order.

The release notes did say that you have to make sure you are not sharing internet on any device for now. iPadOS 15.4 And macOS 12.4 changed things so you may have to start from scratch if your previous setup didn’t transfer flawlessly.

In my case, we had to sign out of iCloud on all devices. That was not pleasant. But I had been ignoring a keychain “permission” pop up and the sync between all the devices needed to be set up again. When I say all devices, every single device that used my Apple ID. My pain was likely caused by running beta versions for several years on my account.

Then signing in, whether they did cleanup instantly while I was on with support or the system does some rekey in the background when the last “connected” device signs out so that the next joins are productive, I don’t know.

I hope someone has a less “nuke and pave” option, but I’m able to control now and so happy all my iOS and macOS devices are now running non-beta versions (for a couple weeks I think).

1
  • I am waiting for Apple to call me back, but I tried logging out of iCloud one by one and then after all together, before logging back in, no change :( - this is on an iPad Air 4, iPad mini 6 and MacBook Pro 13" M1. When I login using a different Apple ID it works fine! - I hope Apple can fix it.
    – Hackeron
    Commented Jul 14, 2022 at 0:03
0

I upgraded MacOS from 13.3 to 12.4 and lost the Universal Control capacity to use the Mac mouse and keyboard on the iPad Pro, it was previously working. I tried signing out of my apple id on both devices, then signing back in, and although that did not initially work, it does now. iPadOS is 15.5 (the latest).

Before, when I was in Preferences / Displays, when I tapped the "Add Displays" dropdown, there were two options, the second which added just mouse nd extended keyboard functionality; then after the upgrade, there was just the option to mirror or extend, now quite suddenly and without explanation, the second option has reappeared.

3
  • Thanks for you response. Did you need to logout of iCloud for a all your devices or just the ones you were using for Universal Control?
    – Jachin
    Commented May 27, 2022 at 14:30
  • I also have this question, I tried to log out and log back in, 1 by 1 on my 2 iPads, my MacBook and iMac, this didn't help. Do I need to log them all out? - should I also log my iPhone out? - Any tips would be appreciated!
    – Hackeron
    Commented Jul 13, 2022 at 23:43
  • I tried logging out of all of them, waiting 5 minutes and logging back in, this did not help unfortunately. I am waiting for Apple to call me back tomorrow, I hope they can help!
    – Hackeron
    Commented Jul 14, 2022 at 0:18
-1

After spending 4 hours on the phone with Apple with 4 separate call backs, I finally got it working!

Initially, it would not work no matter what. We went through multiple cycles of turning universal control off on all devices, then restarting them, then enabling the feature. Many cycles of turning off the display preferences and back on, on the Mac, nothing helped.

She then suggested I turn off screen time on all devices, and it worked immediately! - but only briefly. It worked with the iPad Air4, but immediately disappeared when I woke up the iPad mini 6 (I have 2 iPads and a MacBook Pro 13" M1).

The next step was to try in safe mode, this did not help. Next step was to create a new admin user account on the MacBook, rebooting and logging into this new account, this worked with both iPads! - I was able to use universal control for the first time in months! - but when I tried to log back into my original account, this broke it again, I was never again able to get it to work, not even deleting the user and re-creating it, argh!

Finally the support person said you're going to have to re-install the OS. While a pain in the ass and time consuming, thankfully the iCloud backup makes it reasonably safe, without losing any data. After doing a full re-install of MacOS, everything is working as expected (for now!) - I did not need to do anything on the iPads.

3
  • Interesting. I kinda tried that. But I'm trying to do Universal Control between 2 Macs. On your Mac, how many monitors do you have hooked up?
    – Jachin
    Commented Jul 14, 2022 at 20:14
  • Just one monitor, I couldn’t get it working between the macs but one of them is a hackintosh so it could be that! Commented Jul 17, 2022 at 10:49
  • Update, this stopped working after updating to Mac 12.5, argh! (updated iPads to latest version too).
    – Hackeron
    Commented Jul 23, 2022 at 20:10
-1

I just upgraded to macOS 12.5 and Universal Control is working again! I think the issue was a bug in 12.4 that was preventing Universal Control from working if there were 3 (more than 2) monitors on one of the computers.

6
  • I have the opposite problem, I just updated to 12.5 and universal control stopped working again :(
    – Hackeron
    Commented Jul 23, 2022 at 10:14
  • @Hackeron How many monitors are connected to your Mac? And are you connecting from 1 macOS (computer) device to another? Or is is macOS to iOS?
    – Jachin
    Commented Jul 29, 2022 at 21:27
  • Usually one, but all my testing was just with just the Macbook Pro 13" M1 internal display - it is just 1 Mac to 2 iPads (Air 4 and Mini 5)
    – Hackeron
    Commented Jul 30, 2022 at 11:38
  • @Hackeron you probably already did this, but maybe updating iOS would help.
    – Jachin
    Commented Aug 1, 2022 at 17:00
  • Yes, that was the first thing I did. Commented Aug 2, 2022 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .