14

Some time ago I played around with some custom keyboard layouts for Ukrainian and I don't remember in much detail what I did, but as a result I started to experience this weird bug.

I downloaded a custom layout and installed it. I did not like it much, so tried to edit it with Ukelele and used it for some time.

Now it's long gone from my machine, but I still experience a weird bug, which first appeared at that time. macOS constantly adds a couple of 'Ukrainian - Legacy' input sources.

example

Even if I try to remove them, they will appear the next time I open preferences or reload the laptop. Behavior isn't very consistent though. After I delete them, they're gone from status bar and touch bar (but will be present in the preferences after close-reopen) until restart or log out.

enter image description here

I checked ~/Library/Preferences/com.apple.HIToolbox.plist and it seems to be correct and have only two keyboard input sources I added (US and Slovak)

enter image description here

How should I debug this?

UPD: I just installed my custom keyboard I mentioned on start of text and it behaves exactly the same as Ukrainian - Legacy (but thanks god macOS adds it only once, not three times)

2

3 Answers 3

5

I am one of those who +1'ed the original question. And just a few minutes ago, I finally managed to get rid of this issue. I did that after my friend was able to partially (half of it) solve his similar problem with the bits of my advice. I can't guarantee that my recipe will help you, but it's safe, can be rolled back, and is really simple.

  • create a new user with admin rights;
  • log in, and revise his input methods to ones you would like to have;
  • reboot (not sure this is needed, but..);
  • log in again to that new user;
  • remove ~/Library/Preferences/com.apple.inputsources.plist from your main user. You may want to back up that file as well;
  • overwrite ~/Library/Preferences/com.apple.HIToolbox.plist from the new user to the main user. Double-check ownership and access (chmod & chown are your friends here). You may back up the destination file before as well;
  • reboot;
  • login to the main user and make your checks. At this moment, I got my win.
3
  • 1
    A good and clean fix that solved it for me on MacOS 12. My problem, as with OP, came from tinkering with Ukelele.
    – marquinho
    Jul 13, 2023 at 12:43
  • Thank you very much, this problem was hunting me for over a year. Let's ignore political context here, what I was trying to eradicate, was a flag with 3 stripes of one country associated with the Russian language. So I have created a new input source using Ukelele not containing any flag. After that, by every restart of the machine it was terrorising me creating multiple input sources with that old damn flag. New MacOS versions got rid of national flags entirely (which makes sense because most languages are usually spoken in more than one country). So, thank you once again, you are my savior. Sep 5, 2023 at 15:13
  • Thanks a lot @ZuBB, this workaround helped me to remove the default input source which I replaced with a custom one! Mar 31 at 5:24
0

Accidentally I fixed such issue with a custom layout by entering lower id value in <keyboard group="Value" id="Value" name="Value" maxout="Value"> line in .keylayout file.

Screenshot of keylayout file

-1

What exactly are your worries: That Ukrainian appears three times in System Preferences > Keyboard > Input Sources?

Does it cause any errors? Perhaps could you search for all files with extension .keylayout like follows:

sudo find / -iname "*.keylayout" 2>/dev/null

You will find the Korean layout, which you edited with Ukulele. Remove it. This would be my guess.

2
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 21, 2022 at 12:17
  • 1
    Yes, it irritates me that Ukrainian appears three times and that I can't delete it. It doesn't cause any errors. 'Ukrainian -- Legacy' is builtin keyboard layout, it isn't listed in results of find command
    – OlegWock
    May 21, 2022 at 19:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .