3

I'm on Big sur

I have several disks on my mac. Some of this disks have been changed by others or went wrong, etc. Now they are not there any more. But if I go in my time machine drive I see the backups for them. I need to remove them from the disk, but it seems there's no command for it in tmutil. All I can find is the delete command and all the examples I find they are just for deleting a directory. But not the backup itself.

And if I try the risky delete through osx I get an error telling me that the backup can't be deleted.

I need to remove this drives completly from my time machine drive... as they are taking loads of space.

10
  • Please confirm that the Time Machine backup disk is formatted APFS? If so, you won't like the answer :(
    – Gilby
    Commented May 18, 2022 at 2:46
  • When you say delete the disk - can you show a screenshot or listing of which files you wish to purge? It’s. To clear if you have several disks doing to one destination or several destinations for one or more disks.
    – bmike
    Commented May 18, 2022 at 3:03
  • Time machine backup is NOt formatted as APFS. Whn I say "delete disk" I mean that I have Drive 1, Drive 2, Drive 3, and in time machine I have BACKUP_DATE/Drive 1, BACKUP_DATE/Drive_2, etc. I want to delete the Drive 3 as it doesn't exist any more and I don't need it. And I want to delete ALL BACKUPS FROM ALL THE DATES FOR THE SELECTED DRIVE. Commented May 18, 2022 at 7:39
  • Aah - so a drive shows up as a folder in the backup, so you have the same problem as deleting all instances of a file or folder. apple.stackexchange.com/a/85855/5472 Is relevant with the bypass command. Also this be sure to read the comments. I don’t use bypass very often as it’s very dangerous if you make a syntax mistake. I usually just bench that backup drive when it’s full and start a new one with the old drive excluded
    – bmike
    Commented May 18, 2022 at 8:59
  • that looks a little bit risky... Would this work: ? - Exclude the TimeMachine drive from the TimeMachine program. Delete de "Drive backup" from all the dates by hand. - Reatach the TimeMachine drive to the TimeMachine sofware. I say this because while the drive is in use by timemachine I can't delete "by hand" the drives, but maybe (I've not tested it) I can delete them if the drive is unattached. I can't believe there is no simple way to do it "this drive doesn't exist any more, delete all snapshots to regain space in the drive." And insted of that you have to reformat the drive. Commented May 18, 2022 at 9:15

1 Answer 1

2

If the normal system is saying there is an error, you likely want to stop this attempt to free space. Something is wrong with the system or the filesystem so you want to figure that out if your backups are at risk.

In the past with HFS only systems, the bypass command allowed someone that was sure about which file or folder needed removing to surgically perform the same “delete all versions” of a file that the gui allowed.

Running that on one file (rather than a folder) might be useful to see if there are detailed errors that your system didn’t print when you tried this delete.

If you need any files that were backed up, it’s safer to get a new drive to start a new backup. Then go over the old drive and decide how much of it you need. Just a few files could be hand copied back to the main system, backed up and then deleted. Simpler is to just label the old drive “backups from 2015 to 2022” and archive it on a shelf. Hopefully it will serve you until you are sure you don’t need any data and then you securely erase and put it back in service or recycle it.


Some unsolicited advice, The benefit of backups is you don’t have to know what was lost to get it back later. I wouldn’t risk that if I could safely spend $100 on a new 4 TB drive (for instance). It’s hard to guess your setup though - we don’t know the value of your data, time and budgets for getting more storage or spending time learning why the delete function failed…

3
  • I will try to keep it short. I have a mac with 4 drives. 1 OS drive 1 Data drive 1 Data drive mostly photos (1Tb drive, 500Gb of photos) I have 2 timemachine units. An internal HD of 2Tb and an external 2Tb drive. My photo drive was being funny the last days until it wasn't mounted any more. So I bought a new drive, and copied the data from one of the timemachine drives. So, there was no more PHOTO_DRIVE , BUT there was the photo drive data on the timemachine. But now my new photo drive is not linked to it's time machine drive as it is new and has a new UUID. Commented May 18, 2022 at 16:45
  • I tried to link the new drive and it's backup directory using the command "tmutil associatedisk -a mounting_point volume_backup_directory" to no avail as the system complained that the volume directory was not a time machine backup. So I thought, ok, lets delete this old PHOTO_DRIVE from the internal time machie (2tb) and then let the new PHOTO_DRIVE get backed up. But I am not able to remove the OLD PHOTO_DRIVE backup from the disk. And because it takes so much space, there is not space in the 2tb disk to save the new drive. Also I found other old disk copies in the time mach. Commented May 18, 2022 at 16:49
  • You don’t want any association. Just an erased blank disk, add new destination. The steps you are trying is causing issues, unfortunately.
    – bmike
    Commented May 19, 2022 at 0:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .