To navigate to a folder I often press Command+Shift+G (a shortcut that has worked from NeXT days) and type where I want to navigate to. Starting with one of the updates to Big Sur (I'm still at macOS 11.6.5) the Go to the folder panel appears, is functional (even auto completes correctly), but when I hit Go (or the Return key), Finder fails to navigate to the requested folder whenever it is under Documents. In that case it navigates me to my system drive (MacHD in my case). It seems like a permissions problem, but upon running xattr and ls -le on the directory, nothing stands out to me.

How do I regain the functionality once available through Command-Shift-G? Do others have this issue? Is it a problem in Monterey?

  • On 11.6.5 as well and cmnd+shift+G opens, i type a folder and it works. Have you restarted? or had Disk Utility check for errors?
    – Solar Mike
    May 16, 2022 at 17:44
  • @SolarMike I have restated, updated Big Sur, and just finished running Disk Utility from Recovery. The Cmd+⇧+G works on other accounts on my machine but not on mine. I'm not familiar with the beyond-Unix access controls of the Mac. Where are those constraints of the type "Terminal would like to access X" stored? Maybe I denied the panel access without noticing.
    – Hbar
    May 16, 2022 at 19:14
  • 1
    Does this help? apple.stackexchange.com/a/439835/30895
    – Martin R
    May 16, 2022 at 19:41
  • @MartinR: Yes, thank you, that worked. I had Documents de-selected in my Sidebar. I +1 there, but I would also like to accept it here.
    – Hbar
    May 17, 2022 at 20:14

1 Answer 1


A similar problem was reported in `open folder` may fail due to “untranslocated nodes”, and the same workaround works here as well:

Make sure that the “Documents” folder is selected in the “Sidebar” tab of the Finder preferences.

That seems to be a bug in macOS, and occurs only with subdirectories of “Documents”.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .