I have a MacBook Pro A1990 EMC3215 (2018 15", either i7 or i9 [I'm not sure which]). I'm having trouble reinstalling the OS. When I try a fresh install using Command-Option-r via WiFi, I get a -2100F fail code after about an hour. I followed the steps on https://support.apple.com/en-za/HT201065 to get a fresh install of the OS. At the "Erase your Mac and reinstall MacOS" step, I followed https://support.apple.com/en-us/HT208496.

I've tried to boot to recovery mode via Command-r, but the machine only goes to the prompt to enter the WiFi name and password.

I created a bootable USB with Monterey on it. (My other laptop is mid-2012, so I had to download the .pkg from https://mrmacintosh.com/macos-12-monterey-full-installer-database-download-directly-from-apple/.) When I start with the USB plugged in (via a USB to C connector) and hold the Option key, the USB flashes and I do see the Install Monterey option. However when I choose that option, I'm immediately given the WiFi prompt again, and the USB light goes dead. All appearances suggest that the machine is trying a standard WiFi recovery. After about an hour, I see a -2003F fail code.

I suspect the problem is 1) the current boot is corrupted (hence the lack of Recovery Mode) and 2) the "security chip that offers the prevention of external boot media to be used to startup a Mac" as noted in https://osxdaily.com/2021/08/25/mac-wont-boot-bootable-disk-why/. However, that article goes on to describe that deactivating this security feature requires one to boot into Recovery Mode, which I seem unable to access.

I'll probably go into the office tonight or tomorrow to try a different WiFi connection. (I'm doubtful about this as a solution; I'm currently on a home WiFi connection, which shouldn't be restricted.) I don't have an ethernet to C connector, so ethernet's not a possibility.

I'm currently in South Africa, so taking the laptop in to an Apple store isn't an option.

Any ideas how I might proceed?

Thank you very much in advance for your help.

EDIT: I seem to be able to boot up the laptop to act as an external drive by holding t on start. However, when I connect my mid-2012 Catalina laptop using a USB to USB-C connector, I don't see an external drive. I also don't see an external drive when I connect my 4th gen iPad to the laptop using a USB-C to USB-C connector.

1 Answer 1


Long story short, my work WiFi allowed me to get to the Recovery Mode screen. I'm shocked, but the online advice of trying a different WiFi connection really worked. (I figured what's the difference between one WiFi connection and another.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .