1

I am trying to share some folders and my external USB hard drive through smb for my local network. However, certain folders cannot be shared. The folders appear when go to finder->network and click the selected computer. When I click the Documents folder I received an error message:

The operation can’t be completed because the original item for Documents can’t be found

This only happens with certain folders, to be specific my Documents, Desktop, and as well the external hard drive. I can share my Music, Scans,Movies and even share my local hard drive, but for some reason not the external one. Here is my output

drwxr-xr-x@   17 foo  staff      544 13 Mar 10:05 Desktop
drwxr-xr-x@   15 foo  staff      480 13 Apr 15:11 Documents
drwx---rwx@ 2121 foo  staff    67872 13 Mar 16:54 Downloads
drwx------@   28 foo  staff      896 11 Mar 10:02 Dropbox
drwx------@   95 foo  staff     3040 31 Jan 12:52 Library
drwx------+    4 foo  staff      128 15 Mar  2020 Movies
drwx------+    5 foo  staff      160 15 Mar  2020 Music
drwx------+   19 foo  staff      608 24 Sep  2021 Pictures
drwxr-xr-x+    5 foo  staff      160 10 Aug  2020 Public
drwxr-xr-x   678 foo  staff    21696  3 Mar 15:09 Scans
drwxr-xr-x     2 foo  staff       64 13 Oct  2021 Screenshots
drwxr-xr-x+    3 foo  staff       96 28 Aug  2021 Sites
-rw-r--r--     1 foo  staff  5707217 20 Oct  2021 objc.scan

Here is my /Volumes/

drwxr-xr-x     4 root            wheel    128 14 May 12:58 .
drwxr-xr-x    20 root            wheel    640 26 Mar 01:21 ..
lrwxr-xr-x     1 root            wheel      1 14 May 12:02 Macintosh HD -> /
drwxrwxrwx+ 1151 foo  staff  39202 14 May 12:58 ExternalUSB

I made sure my file sharing was activated and made my folders available for sharing with smb. I tried changing the permission of the folders to 755, changing the groups, and as well owners to root/admin, but it didn't work. Someone told me that there could an issue with extended permissions and ACL, but I am not sure about that. I am running MacOS 12.3.1 Monterrey.

1
  • 1
    ls -le@ will show ACLs and extended attributes if you want to see them. Do you have iCloud sharing enabled for Documents and Desktop i.e. SysPref > Internet Accounts > iCloud > iCloudDriveOptions > Tick for Desktop and Documents Folders?
    – Gilby
    May 15 at 3:16

1 Answer 1

0

When an app or a process is not able to access external drives, the Desktop and the Documents folders, the usual cause is that it has not been granted access in System Preferences > Security & Privacy > Privacy > Full Disk Access.

Now, you would expect that starting file sharing would automatically grant the SMB server process the appropriate permissions, but that doesn't seem to be the case here.

Fortunately, you can set it up yourself:

  1. Open System Preferences and open Security & Privacy > Privacy.

  2. If the pane is locked, press the lock and enter an administrator's name and password.

  3. In the sidebar, select Full Disk Access.

  4. Press the + button.

  5. Press ShiftCommandG and type /usr/sbin.

  6. Select smbd and press Open.

  7. Make sure smbd is enabled:

    enter image description here

  8. Close System Preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .