3

I have two external Samsung X5 2TB Thunderbolt 3 SSDs. Both of them work fine after I reformat them. But when I delete files (and empty the recycle bin), the space on them does not increase. In order to get space back, I need to empty it, reformat, then rebuild up files on it.

So far I have tried the following:

  1. Enabling TRIM. It's enabled, does nothing.
  2. Showing hidden files/folders to make sure nothing is hiding on the drive. There's nothing there, trash on the volume is empty, etc.
  3. I've tried running "First Aid" in Disk Utility. It runs fine and finishes but it doesn't fix the problem.

What could be causing this? I am running MacOS Monterey on an M1 Max laptop.

1.37TB of data but only 31GB free on a 2TB disk

File system thinks I am using 1.97TB

TRIM is enabled

4
  • Yes I saw some of those but there are no local snapshots on these drives that I can find. Terminal doesn't find them either. Also those all say 24 hours, which it has been more than for the data in question. So it should have been purged by now either way. This has been going on through several cycles with these drives -- the only way to get the space back, that I can find, is to reformat them.
    – natarem
    May 12 at 17:56
  • Hmm, strange. Could you perhaps include that kind of details in your question? It will help answerers in writing something that you haven't tried yet. What happens when, after you delete all files you try to write the full capacity? I assume it'll wrongly show the capacity, but I'm curious if it will actually stop you from writing. May 12 at 22:23
  • I didn't check the local snapshots thing until I saw the other answer from @benwiggy. If I delete files and try to write the full capacity, it stops when it gets to the "fake" full capacity, it doesn't recognize the deleted space as being available. The only way to get access to that deleted space again is to do a disk format. I think I am going to try reformatting as exfat or something like that, apfs doesn't seem to work on these disks.
    – natarem
    May 13 at 17:40

2 Answers 2

0

APFS disks do not release the space for deleted files immediately. The files will still exist in an APFS snapshot, which records the state of the disk at a point in time.

Snapshots will be deleted after 24 hours; or after the disk is backed up by Time Machine. The space may be recovered by the file system if needed for new files.

The Terminal command:

tmutil listlocalsnapshots /

will list all the snapshots stored on the drive.

tmutil deletelocalsnapshots /Volumes/Name_of_disk

will remove them.

However, the snapshots' size is usually shown as "Purgeable", so I don't know why you're seeing Zero Purgeable space.

1
  • Thanks for the answer but this has been like this for over 24 hours and I just checked, there are no local snapshots on either one of my TB3 SSDs.
    – natarem
    May 12 at 17:53
0

Just to update this, I tried reformatting as HFS and it does work to delete and recover space. I'm still not sure why APFS is jacked up on these particular Thunderbolt3 SSDs (the same problem is not happening on my internal SSD, other external SSDs, etc) but it doesn't work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .