1

Can someone explain how to download and install Torify for an M1 mac? I've tried installing via Homebrew, and got the following errors:

Warning: No available formula with the name "torify". Did you mean trivy?
==> Searching for similarly named formulae...
This similarly named formula was found:
trivy
To install it, run:
  brew install trivy
==> Searching for a previously deleted formula (in the last month)...
Error: No previously deleted formula found.
==> Searching taps on GitHub...
Error: No formulae found in taps.

I'm on MacOS 12.3.1. I'm looking for this, becuase I want to use youtube-dl via Tor.

1 Answer 1

3

When I typed "torify" into my mac, I get this output:

The program 'torify' is currently not installed. You can install it by typing:
  brew install tor

From here, it is simple to figure out that brew install tor will install torify, but not brew install torify

4
  • 2
    @tomh I am not on am M1 mac, but you attempted to install 'torify' when you should install 'tor'. When i tried installing 'torify', it failed, but when i installed 'tor', torify started working. Also, my error occurred when I tried to RUN torify without it installed, pointing me to a package to download for torify. May 7, 2022 at 14:19
  • Which tool do you have installed to propose packages in case a binary is missing?
    – nohillside
    May 7, 2022 at 16:24
  • 1
    @nohillside github.com/Homebrew/homebrew-command-not-found May 7, 2022 at 17:25
  • 2
    Thanks! Installing 'brew install tor' and then installing 'brew install torsocks' seems to have worked, but youtube-dl is giving an error for the file I need to download. Suspect I need to set the output node for Tor, but haven't worked out how to do that yet.
    – tomh
    May 7, 2022 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .