1

I recently switched out my old Seagate Barracuda HDD for a OWC SSD 3G in my late 2009 iMac 27", fantastic results.

But when restoring from a Time Machine back up made just minutes prior opening the iMac, I faced many issues, namely files were just half restored, permissions were broken and so on.

I then started from scratch with a brand new High Sierra, but now my Time Machine disk is basically unusable: it sort of shows in Disk Utility:

enter image description here enter image description here

But it is not really accessible. Time Machine sort of sees it (by Option-clicking it), but most of the time, does not allow to browse it. When it does, it is super slow and eventually auto eject itself.

I also managed to briefly see it in Finder and manually browse the back-ups, but again, it hanged and eventually ejected.

Now I can not seem to be able to browse it anymore, it just shows in Disk Utility as pictured.

What I would like to achieve:

  1. See if I can browse it to recover some files, via Time Machine or Finder

Additional info: Time Machine restoring was attempted after High Sierra was patched to the latest version, to match the back-up version, via Migration Assistant. I tried all the 4 different USB iMac ports. The drive is a portable Toshiba 1 TB USB 3.0 which served all its life as a Time Machine back-up and was never really needed. Well, until now.

I suspect restoring was broken since I switched to APFS for the new SSD while the back-up was in macOS Extended (Journaled)?

UPDATE 1

Last night, by randomly running First Aid on it, it started to show on the desktop. I then proceeded in moving some files but behaviour and speed were inconsistent: sometimes files would just transfer quickly and fine, other time slowly and ended in an error.

Now the disk is not mounting again, shows another name in Disk Utility and does not First Aid. Any suggestion is appreciated.

enter image description here enter image description here

UPDATE 2

I have noticed that when copy is interrupted, I get error code - 36. I researched it and tried to dot_clean via terminal but no luck, error came up again on the same files. Size seems unimportant, it came up with an image file of a couple MBs and with a video file of 3+ GBs.

Nevermind the inconsistent mounting of the hard disk, by insisting/sheer luck it eventually shows in Finder. Now my objectives are:

  1. Be sure that the actual copy ends with no error -36, no matter if it going to take several hours

  2. Do not have the hard disk ejected, even if I must say it always happens after error -36 so they must be tied

3
  • If I had to guess, the disk itself was dying an the attempt to read from it to restore the backup was the final push. If the data is of high value, you may wish to contact a data recovery place, otherwise, remember the 3-2-1 backup rule as well as test your backups.
    – At0mic
    May 8 at 6:25
  • Someone with more experience than me may be able to help you recover the drive via diskutil commands if the drive isn't dead, though.
    – At0mic
    May 8 at 6:28
  • Thank you for your input. So, data on it is not really important, otherwise I would not have started from scratch with a fresh macOS installation. It is mainly movies, all the important stuff was in iCloud and back in place. Some late night tinkering yesterday has produced results: I randomly run a first aid on it via Disk Utility and now it shows mounted on desktop every time. I am starting to move stuff, will report back once done.
    – EVR
    May 8 at 7:49

1 Answer 1

0

Well, I have no idea why but by just insisting and transferring files via Finder (not the Time Machine interface), I eventually made it.

I just lost 1 series, 1 movie and a folder with 32 screenshots, no matter what they where always bring up error -36. Not too bad for over 500 GB of data.

My advice is, if you are in a similar situation, try to run First Aid on it, use Finder, just have the patience to transfer one file at a time to identify files that will be throwing the error and drop them, they will never copy correctly.

I will then erase this disk and set it up as a new Time Machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .