0

While running the .pkg file to install Acrobat, a generic prompt is raised after I enter the serial# indicating that installation has failed. When I run Acrobat, it prompts me to enter the serial again, and that immediately raises the following dialog:

Acrobat Error

I don't have reason to think that the installer is damaged. The package file has been used successfully through Munki (on earlier MacOS versions) for a long time and I've tried copying it and running it manually with the same result.

I googled the error but the most common solution from Adobe is to change the permissions on Library/Application Support/Adobe/SLStore, but it doesn't exist. Adding the folder and then granting the permissions also fails.

The Macbook is updated and running MacOS 12.3.1

  • Does error 16 apply to missing access to some other system resource for storing the serial #?
  • Could there be a missing system integrity protection dialog requesting access to something?
  • Could this be a Rosetta2 issue?
  • Is Adobe cursed?
2

2 Answers 2

2

It's possible that Adobe uses python scripts in its installers, and Apple removed the system python from Monterey 12.3.

But realistically, this is a question for Adobe support. Any reason you're not using Acrobat 2022?

3
  • I don't have much faith that Adobe will provide a helpful response, but I am trying. Having the answer to this question might be helpful for the community. Python was a good idea, installing 2.7 fix the problem either sadly. May 5 at 13:47
  • 1
    @DanatheSane Installing python won't work if their scripts point directly to the system python (which a lot of scripts do/did).
    – benwiggy
    May 5 at 13:58
  • So it turns out the installer provided by my organization's licensing people is outdated, the newest one works fine. Thanks. May 7 at 0:02
1

It is likely that @benwiggy's suggestion about Python 2.7 being removed from Monterey caused the problem. It turns out that my vendor provided me an outdated installer, while the latest one installs correctly.

1
  • Also my question about using the most up-to-date installer....!
    – benwiggy
    May 7 at 8:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .