0

Today I was working in my USB 6TB WD_BLACK on MacBook Pro 14" M1, everything was working fine, removed it, sometime later I tried to connect the HD again but it won't show, this is the second time that happened. The first time I "solved it" by connecting in Windows and running "check disk for errors", Windows says the drive has no errors, after that I tried connecting again and the drive showed up. I don't know what is causing this...

The drive is greyed out in Disk Utility.

When running first aid in Disk Utility I got the following error:

Checking the filesystem and repairing if necessary and possible
The volume has already been dismounted.
Running fsck_exfat-y-x/dev/rdisk6s1
The filesystem output code is: 1.
Restoring the original unmounted state
Filesystem scan or repair failed::(-69845)
The operation failed

The HD works great in Windows, I tried the HD in another MacBook Air M1, the same problem happens.

I restarted many times already, what should I do?

0

You must log in to answer this question.

Browse other questions tagged .