12

The past week I upgraded from macOS 11 Big Sur to macOS 12.3 Monterey. My Magic Trackpad 2, which connects via Bluetooth, lags. If I simply move my finger, it takes a short time before the mouse movement starts onscreen. The same for a swipe for Spaces: I'd swipe, and only the second half of the swipe gesture was responded to. If I tap, I have to press, even though Tap to Click is turned on. Some experimentation showed that if I rested my finger on the trackpad for half a second, movement was then immediate, so it seems the trackpad is taking some time to realise my hand is present and then respond.

I have tried connecting it via USB; restarting my Mac; and ensuring its battery is fully charged. But it's still lagging. How do I solve this?

2
  • I also have this issue, and I did find and continue to use the off-and-on-again power toggle. BUT - I'm speaking to you now Apple - this happen way too often to be tolerable. I haven't exactly found the pattern but it seems to be related to load and possibly monitor-window fast tracking back and forth. I've got an M1 fairly new Mac with 16GB, nothing here should faze this machine for something so simple as trackpad performance. May 1, 2023 at 13:09
  • @CorneliusTalmidge Apple doesn’t read these posts; at least not officially. To address them directly, submit your commentary to them directly at feedback.apple.com
    – Allan
    May 1, 2023 at 21:42

3 Answers 3

14

Solution: turn the Magic Trackpad off and on again. It's easy to forget they have a power switch: on the back edge where the power cable plugs in, there is a small sliding switch. I turned it off, waited for ten to fifteen seconds, and turned it on again.

Once it reconnected, it now responds quickly as it did when using it with Big Sur.

Note: There is still sometimes a slight perceptual response delay when I first touch and drag after not having used it for a minute or so. It's much, much smaller than half a second (too small to quantify, maybe fifty milliseconds?) and can mostly be ignored.

This Apple Discussion was very helpful, reminding me such a simple solution exists. It also lists other things to try if this solution does not help you. If so, please edit this answer to add in what worked for you!

1
  • 2
    The slight lag on first touch after being left alone for a while is to be expected. All this type of device 'nods off' after a timeout, to save battery.
    – Tetsujin
    Apr 27, 2022 at 14:20
2

In my case, the problem was actually related to connecting AirPods Pro to the Mac which I also connected Magic Trackpad. It turns out that when I disabled both Mac and iPhone to connect automatically to AirPods the trackpad is no longer lagging.

Option on Mac can be found in System Preferences > Bluetooth > hit Options under your AirPods and then:

Screenshot of the Bluetooth Preference Pane options

1
  • I think this option does no longer exist.
    – soupdiver
    Nov 18, 2022 at 8:54
0

I just replaced the Duracell batteries with rechargeables, and the trackpad started stuttering every few seconds. Not sure that's the culprit, but it's the only thing that changed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .