0

I got some problem with indexing of disk, Spotlight, searching in finder and file-management.(MacBook m1 2020)

Finder is loading a lot of time, searching in it does not work, Spotlight does not work and rotation of files from dir to dir also works a lot of time.

I tried to reindex disk like on man of Apple. I tried to do that from terminal with sudo mdutil -a -i off/on in common and safe mode and

sudo mdutil -a -i off
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
sudo mdutil -a -i on

by turning off System Integrity Protection. Also I reinstalled OS (moneterey 12.3.1 now). One more thing, that when I wrote sudo mdutil -a -i on in terminal in safe mode, it told me, that "indexing and searching not working" or something close to this. I tried to "heal" it with Disk Utility but it didn't show any problems with it. So I tried to find "metadata_never_index" and fix it, but there is no success.

Apple Tech-support said that it could be problem in core of mac and some script could be root of this problem. May be there are some problem in my script, which killed my part of system? Or how can I fix problem with finder long loading and "System properties -> Spotlight -> confidentiality" long loading. After it loaded and I add my disk in list, it gave me error like on first screen.

1 : Exception list error. Failed to add or remove object due to an unknown error.

2 : script

EDIT:

3 : I got it after running sudo mdutil -E /

2
  • Please don't repost questions which are on hold. Improve the question instead so it can be reviewed and reopened.
    – nohillside
    Apr 19 at 18:16
  • Also, don't use pictures on 3rd party sites. If it is a text output (like the 3rd link), just copy/paste the command you run and the output you got and format as code. If it is something else, use the inlining functionality of the editor.
    – nohillside
    Apr 19 at 18:23

1 Answer 1

2

The usual procedure to reindex Spotlight is just:

sudo mdutil -E /

You should not need to do anything else. Turning off SIP and unloading the Spotlight LaunchDaemons is unnecessary and may cause more problems.

Other things to look at are to check that the disk is formatted to APFS; and remove any manual alterations you have made to the system environment.

You may have to erase, install the OS, and then transfer your software.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .