0

I wanted to share a folder on my MacBook Air running Big Sur to a MacBook running Monterey. So I used Settings -> Sharing, and then let's say, add the folder Foo to the sharing list.

Now on the Mac running Monterey, I used Network in Finder, and click on the other Mac. It showed nothing and it seemed I had to use "Connect As"... but it seems I have to connect as the user on that machine with the password, and once it is done, I can see the whole hard drive of that Mac, which is not what I want to do.

So how I can not "overly share" something?

2
  • Did you do it like described in Apple support document Set up file sharing on Mac Apr 18, 2022 at 5:44
  • I moved forward a bit by doing the method as in my comment under @Gilby's answer... and there is one catch: one computer always connect by Apple ID and can access everything and Keychain app cannot forget it Apr 18, 2022 at 9:30

1 Answer 1

2

If File Sharing is ON, connecting with an administrator username (of the shared computer) will show all disks. That is expected.

When you share folder Foo, you can specify user access. You can enable it for a non-administrator and then a connection using that non-administrator username and password will just show Foo.

You can't restrict an administrator to just one share.

1
  • 1
    so I think a method is: share a folder, and then in Settings -> User and Groups, set the Guest to be able to access shared folders, and then on the other computer, Connect As: Guest... the only trouble I am facing is: one Mac always connect by using the Apple ID, and can access everything. I tried to use the Keychain app to remove everything related to that computer but no use: it always connect by the Apple ID and can access everything Apr 18, 2022 at 9:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .