I installed rEFInd boot manager because I wanted to add a linux partition. I already had bootcamp set up.

However, after installing rEFInd, my Mac UI scaling was too large and slightly blurred. I have no idea why that would happen so I removed it.

My process was as follows:

sudo mkdir /Volumes/efi
sudo mount -t msdos /dev/disk0s1 /Volumes/efi

Then I deleted the whole efi folder and unmounted the volume.

This removed rEFInd and the scaling issue was fixed. I can't remember if I tried rebooting by holding down the option key or not so it's possible the Windows boot option was removed at this point and I hadn't noticed. Perhaps it was from what I did next.

I then tried to install rEFIt boot manager to see if that was any better. I ran the package but didn't move over the efi folder to the root. I suppose I may still be half way through the installation?

At this point I'd lost faith in boot managers and wanted to just try installing Xubuntu and seeing if grub2 would work. I haven't yet got to that point because I have now noticed I can't boot to Windows bootcamp.

If I hold the option key when rebooting, it no longer appears. Even if I change the startup disk to Bootcamp, it boots to Mac anyway.

Have I removed something needed for Windows to boot when removing the /Volumes/efi folder. The video I was following just removed it, but perhaps they didn't have bootcamp and didn't need to do something different.

I have considered continuing the rEFIt install, because perhaps that is the issue. But I thought I'd ask for help at this point, because I don't want do something worse because I'm not really confident that continuing rEFIt will work.

Just to clarify what I did, I mounted the rEFIt.dmg and ran the rEFIt.mpkg; that is all. The next steps would have been to run the 'enable-always.sh' script and to moved the 'efi' folder to the root. Could only running rEFIt.mpkg and not continuing with the rest cause this issue with Windows?

I've tried following videos for how to removed rEFIt. It says to remove the 'efi' folder from the root (I didn't have that anyway), and to remove the folder from /Library/StartUpItems (I also didn't have anything there either).

And finally, to make matters worse, I also resized the MacintoshHD partition to make a 35GB partition for Xubuntu. And in writing this post, it has suggested another thread from someone who said they lost the ability to boot into Windows after resizing the partition. So is that my problem?

This is terrible.

I would be amazing if I could get some guidance with this please.

EDIT (added more details):

It's a 2019 iMac running Big Sur 11.6.1. The Windows version is Windows 10 Home (I can't give any more information on that) which is updated regularly when asked to at startup/shutdown. I installed Bootcamp via the assistant, and have done nothing to the assistant since.

The output of diskutil list is:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk2⁩         843.0 GB   disk0s2
   3:       Microsoft Basic Data ⁨X⁩                       35.0 GB    disk0s3
   4:       Microsoft Basic Data ⁨BOOTCAMP⁩                122.0 GB   disk0s4

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *28.0 GB    disk1
   1:                        EFI ⁨EFI⁩                     314.6 MB   disk1s1
   2:                 Apple_APFS ⁨Container disk2⁩         27.6 GB    disk1s2

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +870.5 GB   disk2
                                 Physical Stores disk1s2, disk0s2
   1:                APFS Volume ⁨Macintosh HD⁩            20.3 GB    disk2s1
   2:              APFS Snapshot ⁨com.apple.os.update-...⁩ 20.3 GB    disk2s1s1
   3:                APFS Volume ⁨Macintosh HD - Data⁩     702.3 GB   disk2s2
   4:                APFS Volume ⁨Preboot⁩                 397.5 MB   disk2s3
   5:                APFS Volume ⁨Recovery⁩                626.4 MB   disk2s4
   6:                APFS Volume ⁨VM⁩                      3.2 GB     disk2s5
  • 1
    What model/year Mac? What version of macOS (OS X) is installed? Which version of Windows? Did you use the Boot Camp Assistant to install Windows? Have you upgraded the Windows version since first installing Windows? Did you modify the Boot Camp Assistant in any way? Can you post the output from the command diskutil list? Apr 17, 2022 at 16:06
  • @DavidAnderson Hi, I made an edit adding more details from what you asked. :) Apr 17, 2022 at 17:24

1 Answer 1


A UEFI booting Windows will have boot files stored in the EFI/Boot and EFI/Microsoft folders in the FAT32 formatted volume stored in the /dev/disk0s1 partition. In your question, you state "I deleted the whole efi folder". If this is true, then you deleted the Windows boot files.

You can recreate the deleted files by booting media which can be used to install Windows. The procedure would be as follows.

  1. In you case, you erase a flash drive to ExFAT format and Master Boot Record scheme. Mount a Windows 10 ISO and copy all files to the flash drive. Use the Boot Camp Assistant to download the Windows Support Software. Copy Windows Support Software to the flash drive. The BootCamp and $WinPEDriver$ folders should be in the root folder on the flash drive.
  2. Use the Mac Startup Manager to EFI boot from the flash drive media. You will have to change the Startup Security setting to allow booting from external devices and perhaps no requirements on the bootable OS.
  3. Proceed to the point where a product key is asked for. You do not need a product key. Press the key combination shift+F10 to open a Command Prompt window.
  4. Enter the commands below.
    list volume
  5. Determine the volume numbers for the EFI and BOOTCAMP volumes. Here I will assume EFI is volume 1 and BOOTCAMP is volume 3. When entering the commands below make the appropriate substitutions.
    select volume 1 
    assign letter=s
    select volume 3
    assign letter=w
    bcdboot w:\windows /l en-us /s s: /f uefi
  6. Exit the Windows installation by clicking on the red box with the X.
  • Thank you so much for this! I have one issue though. I am on step 5, but when I run list volumes I get two EFI volumes; both identical except one is 200MB and the other 300MB. Here's a picture. What do I need to do in this case? Just to let you know, in case it makes a difference, I had a problem downloading the Windows Support files from Bootcamp Assistant. Instead I used this script to download it. Apr 18, 2022 at 13:55
  • The list volume command entered into diskpart is displaying sizes in MiB instead of MB. You want to use the EFI volume on the same drive as the BOOTCAMP volume. This would be the EFI volume with a size of 200 MiB (which is 209.7 MB as shown in the output of diskutil list). Apr 18, 2022 at 15:00
  • I have heard of brigadier, but have never used it. I have my own way to download the Windows Support Software. I would assume brigadier produced a BootCamp folder of approximately 1.3 GB in size and a $WinPEDriver$ folder of approximately 64 MB in size. Apr 18, 2022 at 15:13
  • Thank you for your help, it worked; I can boot into Windows now! By the way, just for anyone who might read this later, you meant to put assign letter=w exit bcdboot w:\windows /l en-us /s s: /f uefi exit I was entering the bcdboot command into Diskpart before I realised you meant to exit out first. Apr 18, 2022 at 17:21
  • You should be able to edit my answer and make any necessary corrections or improvements. In this case, I made a correction. If you wish, you can review and see if this is what you meant. Apr 18, 2022 at 17:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .