0

I'm having an issue with the app SelfControl not blocking one website, namely Chess.com. It seems to block everything else just fine. I tried entering the domain into my hosts file in terminal as well, to no avail, although it is blocked in Firefox (presumably due to my hosts edit). I've had issues in the past with other websites blocking in Firefox after being entered into my hosts file, but not Safari. I've also tried quitting Safari and even disconnecting my WiFi briefly in the hopes that that would force it to read the hosts file correctly, but that didn't work.

Does anyone know how to get safari to read the hosts file once other apps confirm it’s correct?

1 Answer 1

1

Managed to solve the problem by flushing the cache and restarting the computer again. Hooray.

sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder
1
  • 1
    Thank you for editing this to show the command used for the cache flush - it will it help others learn which tool worked for you.
    – bmike
    Commented Apr 16, 2022 at 11:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .