I recently acquired a MacBook Pro (Retina), OS Monterey, and turned iCloud syncing on for Documents and Desktop. It had downloaded (made local copies) more than 200GB of files from my iCloud, then auto-deleted half of them (locally), "Optimise storage" is checked.

After about a day, it started a download of that large amount of files again, it took nearly 5 hours, although I hadn't clicked the download or remove download button near the files. It repeated; it happens once in about +/- 5 days plus the total size of files being downloaded is always different. The cache which is created by this process can be as large as I have 1 GB of the local storage remaining (totally I have 255 GB). The button X near the progress of download isn't clickable. I want to keep important files locally and download any other ones if they are needed.

In another thread someone suggested using this command killall bird && rm -rf CloudDocs, after removing them, it just starts re-uploading and re-downloading all possible files, which takes much time. Please tell me how to get rid of this auto re-download/upload, it is a useless process that eats system resources.

enter image description here

  • Welcome to Ask Different. I can't say why files were initially downloaded and then half of them were deleted locally, but as far as I'm aware you can't configure iCloud Drive to keep "important files" only. According to Apple, when you enable Optimize storage, "the full contents of iCloud Drive will be stored on your Mac if you have enough space. Older Documents will be stored only in iCloud when space is needed."
    – jaume
    Commented Apr 14, 2022 at 13:28

1 Answer 1


You might want to check out this site; it has a couple of apps that allow you to block uploads of certain files... I've used them on a couple of occasions and they seem to operate as advertised.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .