1

I'm on a Macbook running Vnc Viewer (6.21.406) connected to x11vnc (0.9.13) running on my work Linux box (redhat 7.9 Maipo) over a ssh link. Everything works fine except that I typically use control-click on my Macbook to do a right click. This works in Chrome, Eclipse, Messages, etc.. For some reason this key/button combination not longer gets correctly remoted to the Linux box. Eclipse, p4v, Chome, etc. doesn't understand it.

This used to work but I'm wondering if a system upgrade recently changed some settings or something. I've run xev under linux and it shows the control and the click appropriately so maybe the linux applications don't know what control-click is? Maybe something was mapping control-click to be right-click automagically before and is no longer?

Does this sound familiar to anyone? Any ideas what I should try next to resolve this?

Thanks for any help.

3
  • 1
    Ctrl click doesn't even work in a VM running Windows. It demands an actual right click.
    – Tetsujin
    Commented Apr 12, 2022 at 14:57
  • Yeah thanks @Tetsujin. I thought initially that the applications knew it natively but I'm wondering if something used to magically map it to an actual right click.
    – Gray
    Commented Apr 12, 2022 at 14:58
  • 2
    Wow, after fighting with this for a couple of days, I just found the Vnc Viewer setting that resolves it. Sigh. I'll post my own answer.
    – Gray
    Commented Apr 12, 2022 at 15:01

1 Answer 1

3

Maybe something was mapping control-click to be right-click automagically before and is no longer?

I've been fighting with this for a couple of days but I just figured it out 10 minutes after posting this question. I'm not sure when but I must have either upgraded VNC Viewer and it changed the default or its settings got whacked recently somehow.

Under VNC Viewer → Preferences → Expert there is a Emulate2 setting that needs to be set to True. The description of the setting says:

Allow a VNC Viewer user to emulate a missing right mouse button by holding down the Ctrl key while clicking.

Here's the description of the Emulate2 setting from the RealVnc page.

Hopefully this helps someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .