2

So I have a new Mac M1

I'm trying to set up the terminal as it was in my previous system.

The problem now is that when using option+arrow (left or right) it jumps to the next space character instead of the next special character.

I have set the keybindings to the "natural text editing" preset in iterm2.

In summary. This happens:

 /example/path/here       option->         /example/path/here
^                                                            ^
cursor                                                       cursor

What I want

 /example/path/here       option->         /example/path/here
^                                                  ^
cursor                                             cursor

1 Answer 1

1

So essentially my problem was with zsh. The default word separation behaviour is different there.

To fix it I just had to include this in my ~/.zshrc file:

# Bash-like navigation
autoload -U select-word-style
select-word-style bash

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .