3

I try to type the left option key and n for typing ~ on my iterm2 but it doesn't work. When I do the same with the right Option key I can type a ~. After it I can type ~ with the left Option key until I have press the spacebar.

My notebook is running Big Sur 11.5.1 and I use a german keyboard. My system language is english.

I'm total confused and have no idea why it's not working for pipe and tilde :/

5
  • 1
    Does this happen in other apps - like Terminal or Notes?
    – mmmmmm
    Apr 7, 2022 at 11:01
  • 1
    What language keyboard do you have & what is your input language set to?
    – Tetsujin
    Apr 7, 2022 at 11:03
  • My Keyboard Input source under System Preferences is German and this happen only in Iterm2 :/
    – ToyRobotic
    Apr 7, 2022 at 11:56
  • This may be different depending on your input language, but for me opt-n doesn't type a tilde, it puts text entry in a mode where the next character will be combined with a tilde. So typing opt-n followed by another n types a ñ. Typing opt-n followed by space does insert a ~, but I wonder if it's not "typing" a ~ in the traditional sense which a shell might require. To type a tilde on my qwerty keyboard there is a key to the right of the left shift, and on other keyboards I have seen it to the left of the 1. Sorry I don't have a complete answer.
    – Cai
    Nov 15, 2022 at 14:32
  • I guess only screenshots of keyboards could help for such issues, right?
    – jan
    Dec 7, 2022 at 8:47

1 Answer 1

1

Had the same issue with a French keyboard, found the answer here. You need to configure in iTerm settings > Profiles > Your profile(s) > Keys > Left/Right Option Key to "Normal" for that key to work as usual.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .