My separate keyboard (a Das Keyboard 4 Ultimate with ISO layout) has, to my chagrin, a different and erroneous keyboard mapping than the MacBook's built-in (also ISO).

The biggest annoyance is the different mapping of the ' and < keys.

The built in laptop keyboard is like so (Norwegian locale, ISO layout):

enter image description here

While the separate keyboard behaves like so (ANSI layout):

enter image description here

This is not the correct layout. E.g. the Enter/Return button is wrong (1 row). It should be like this (again ISO layout):

enter image description here

Note that the Enter/Return button is 2 rows high here.

Unfortunately, the Mac setup does not fully recognise the keyboard:

enter image description here

… even though it lists it in System preferences, under Modifier keys:

enter image description here

Changing between ISO and ANSI does not help:

enter image description here

Note that the Ultimate keyboard is completely blank:

enter image description here

Finally, on the Keyboard Setup Assistant intro screen, it is stated “Your Logitech device cannot be identified and will not be usable until it is identified” (Emphasis mine). While I have a Logitech mouse, the keyboard is, as described, from another manufacturer. I have never attached a Logitech keyboard to the computer.

enter image description here

I have tried to search for answers here on Stack Exchange. I have found similar topics like this, this and this, but none that answers this issue.

  • 1
    Ah, OK. I see it now.
    – Tetsujin
    Commented Apr 7, 2022 at 8:51

3 Answers 3


After removing the com.apple.keyboardtype.plist file (found in /Library/Preferences/) and restarting, the Mac stopped referencing the non-existent Logitech keyboard. I could now use the Keyboard Setup Assistant, and finally the ISO layout was respected, solving the problem.

enter image description here

FWIW, this is the binary content of the plist I ended up with:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">

If deleting the plist files doesn't work (it didn't to me) I have found in some answer to old similar question that after reseting to default the shortcuts this issue may be fixed:

System Settings -> Keyboard -> Keyboard Shortcuts -> Restore defaults

(And reboot)


Managed to switch from ANSI to ISO by installing karabiner-elements with

brew install --cask karabiner-elements

and then from the karabiner app, go to Virtual Keyboard and select from the dropdown list of Country Code 0 option ISO instead of ANSI.

New contributor
Cătălina Focșa is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .