0

MARKED AS SOLVED BUT NOT REALLY - the keyboard started working again after a couple of weeks. I have no idea why, nothing has changed in the setup / connections / software or configuration. So much for Apple products that "just work".

I use a MacBook Pro 15" 2019 (running BigSur 11.6.5) supplied by my employer as well as a personal linux PC, switching between them with a KVM.

I've been using my USB keyboard (Fnatic Gear RUSH Red Silent) for nearly three years without issue on both systems, but 2 days ago the Mac has completely stopped working with the keyboard and I can't understand why:

  • typing any key on the keyboard has no effect at all, including all letters, numbers, modifiers, arrows etc
  • the keyboard is recognised by MacOS and shown in the Keyboard control panel (clicking on "Modifier keys" shows a dropdown selection for connected keyboards, including mine). It's definitely not a connection issue or a device issue, as it's clearly recognised as a keyboard
  • if I click the "Change keyboard type" button, the standard dialog asks me to press the key to the right of the left Shift key (as I did when I first connected the keyboard years ago), but now when I press the key, nothing happens
  • the keyboard works fine on other machines
  • I have to enter a boot password as the disk is encrypted; at this password prompt, the USB keyboard works fine. It stops working once the OS is loaded
  • I have tried direct connection (with a USB A to C adapter of course) to all 4 ports, as well as the connection I normally used which was never an issue before (through a USB dock and then the KVM which is effectively a USB hub)
  • I have tried disconnecting everything else and connecting only the keyboard, and it still didn't work
  • another USB keyboard connected in any way (direct through the same USB A->C adapter or via dock+KVM) works fine. It's a crappy dome keyboard and I would like to use my nice mechanical keyboard instead.
  • I have reset the SMC and NVRAM
  • I have culled basically any files that match ~/Library/Preferences/com.apple.keyb as well as /Library/Preferences and rebooted
  • the keyboard is still not recognised, even in Safe Mode
  • I normally use UK PC layout (not UK Mac). I have tried various layouts and they make no difference
  • I cannot and will not update to Monterey at this stage, because a) my employer doesn't fully support it yet, and b) this setup worked fine on BigSur until 2 days ago. I don't want to upgrade with everything that entails, on the remote chance that it might magically help (there's no reason at all why it should)
  • BONUS POINTS: the RUSH keyboard has a built-in USB hub. The other USB keyboard works fine through this USB hub, but keypresses on the RUSH still do nothing
  • MORE BONUS POINTS: I've noticed some Fn+ combinations work and are recognised as multimedia button presses. The keyboard has an Fn key and in combination with F1->F6, these produce multimedia control keys. This works.

I suspect this may have something to do with "mapping" keys to keycodes or something like that. As detailed above, I have tried setting different keyboard layouts but it's made no difference.

I have tried contacting Apple Support who couldn't solve the issue. If anyone has any suggestions I would greatly appreciate the help.

2
  • Don't bother with trying connections, keyboard layouts or updating to Monterey - that's not the problem. Have you tried creating a new user on your Mac - does the keyboard work when you login as that user?
    – jksoegaard
    Apr 7 at 8:55
  • I have, and it still doesn't work, hence I'm guessing it's something at the OS level and not the user level. Also, I've just found out that the multimedia keys do work (Mute, Volume Up/Down, Play/Pause and Track Next/Previous).
    – Steve M
    Apr 15 at 13:30

0

You must log in to answer this question.

Browse other questions tagged .