1

Firstly, I really apologize for what I've been doing so far on my MacBook Pro 2015.

I was trying to install a Kali dual boot on my Mac, and this is what I did before my MacBook didn't boot up my startup disk:

  1. I started Kali in live mode and used a tool called gparted to shrink the disk, so I could have a little space to install Kali.

    I didn't try to shrink the main disk but the other disk that has "MacOS journal plus volume" HFS+, labeled "Mandel".

  2. When gparted was done, I restarted my Mac and booted into macOS.

  3. I fired up Terminal and ran this command:

    diskutil list
    

    to list all the available disks in the system.

  4. I resized the main disk0s1 partition, which is the Macintosh disk, by running this command:

    diskutil resizeContainer /dev/disk0s1 160gb
    

    to reduce the disk space from 161gb to 160gb.

  5. When it was complete, I typed

    diskutil list
    

    and spotted FFFFFFFFFFFFFFFFFFFFFFF in both disk0s1 and disk0s2.

    (disk0s2 is the one I ran gparted on, while disk0s1 is the one I'm trying to resize with Terminal.)

I noticed the startup disk wouldn't boot my Mac, since FFFFFFFFFFFFFFFFFFFFFFF is a sign of scratch, and I ordered an external hard drive that has 320gb space, and I'm trying to install OS X 10.11 El Capitan on the external drive, but it get an error that says that the operation needs additional things to install. I realized it needs SATA the ln quickly I plug in the cable and it start installing until I'm out of packets (data)

Anyway, I haven't installed El Capitan yet, and if there is any other idea I can take to just start up the disk, it should be better. I've tried a lot of different ways like this tool in Kali called testdisk.

I can see my disk in the machine, but I don't know how I can boot my Mac again to just go back to my Mac main Desktop.

2
  • See if any of these help… apple.stackexchange.com/search?q=ffffffff
    – Tetsujin
    Apr 6 at 13:53
  • @Tetsujin no none of this help me ..with the fact when I type this command diskutil info /dev/disk0 , the Device / Media name: Disk Image & Protocol: Disk Image* instead of PCI
    – Mandelord
    Apr 7 at 0:22

0

You must log in to answer this question.

Browse other questions tagged .