0

I am trying to run mbsystem (a command-line tool for geodata processing) that for some commands uses a GUI based interface (e.g. if i type 'mbedit' in the command line, a window should open where i can manually edit geodata). For this, i needed to install XQUartz but whenever i try the GUI, the error message 'Couldn't find per display information' occurs.

Xclock, xeyes, xterm all work fine, it's just in combination with mbsystem. I spend ages googling and trying a lot of things, Logging in and out, reinstalling, changing installation order etc. didn't work.

DISPLAY is set to /private/tmp/com.apple.launchd.Ws5cVK5Ody/org.xquartz:0, setting it to localhost:0 or just :0 still throws that error.

I'm helpless - can someone give me a hint?

4
  • Do you try to run mbedit from Terminal, or do you run it from xterm?
    – nohillside
    Apr 6, 2022 at 6:42
  • Also, where did you install mbsystem from, can you link to a page where others could download it from to try themselves?
    – nohillside
    Apr 6, 2022 at 6:44
  • And: Has your Mac one monitor or several?
    – nohillside
    Apr 6, 2022 at 6:54
  • Hej, htanks for the quick answers! mbsystem ist from here: mbari.org/products/research-software/mb-system I tried rnning mbedit from both xterm and terminal, zsh and bash, always the same error. I just use the laptop without a (second) monitor!
    – Mia Mia
    Apr 6, 2022 at 7:21

0

You must log in to answer this question.

Browse other questions tagged .