3

I tried to follow the existing guides explaining how to make a bootable install USB drive for OSX Monterey. However after downloading Monterey, formatting the USB, and running the following as root:

/Applications/Install\ macOS\ Monterey.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled/

I receive this error:

/Applications/Install macOS Monterey.app does not appear to be a valid OS installer application.

-- Other Notes --

  • I also tried running the installer all the way then cancelled before restarting, yet it still gave the same error
  • USB stick is formatted as Mac OS Extended (Journaled) and has 30+GB of space
  • My MacBook Pro has M1 chipset
4
  • You write "I also tried running the installer all the way until the end, yet it still gave an error". Which error?
    – jaume
    Apr 5, 2022 at 10:47
  • Same error, will update the Question
    – Bastion
    Apr 5, 2022 at 10:49
  • Thanks, if you can neither execute createinstallmedia nor run the installer, I'd say the app is corrupt, you may want to delete it and download it again.
    – jaume
    Apr 5, 2022 at 11:27
  • 1
    What went wrong is that the required 12 GB of "Shared Support" data was missing from the Monterey install folder. I just copied it over and then it worked! See my answer below.
    – Bastion
    Apr 6, 2022 at 6:47

3 Answers 3

10

There is a great answer here: https://discussions.apple.com/thread/254003944

From that thread, the issue is that the installer downloaded from the macOS app store is just a skeleton installer, and does not contain all of the content.

To fix this, delete the one downloaded from the App Store.

Then go into the terminal and find which full installers are available:

softwareupdate --list-full-installers

Pick the version of the one you want, and then run the following command (assuming 12.5 is the one you want to download).

softwareupdate --fetch-full-installer --full-installer-version 12.5

This will download a full installer that should be capable of running createinstallmedia.

5

Answering this draws on answers from previous OSX upgrades, but it is a little bit different this time around.

1. How to create a USB install disk, this part was already done:

  • Format a USB as Mac OS Extended (Journaled), and make sure the volume is named "Untitled"

  • Go to https://apps.apple.com/au/app/macos-monterey/id1576738294?mt=12 and click Get

  • Run the installer to the end but DO NOT restart. Instead I hid it and left it in the background (I suspect quitting may unmount the required volume).

2. Now to fix the error run this from Terminal:

sudo cp -Rv /Volumes/Shared\ Support/   /Applications/Install\ macOS\ Monterey.app/Contents/SharedSupport/

This is the part that changed from previous OSX upgrades. The required install data was now placed in the Volume "Shared Support".

3. Finally, create the bootable USB:

sudo /Applications/Install\ macOS\ Monterey.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled/

PS - My answer draws on this one for High Sierra

2
  • In your question, you state "I also tried running the installer all the way until the end, yet it still gave the same error". In your answer, you state "Run the installer to the end but DO NOT restart". Do still get the same error in your answer as you stated in your question? Apr 5, 2022 at 13:50
  • No more error after copying the "Shared Support" volume data into the Install MacOS Monterey application folder. This is what was missing .. about 12 GB of data.
    – Bastion
    Apr 5, 2022 at 23:43
-1

This was helpful - to resolve the /Applications/Install macOS Ventura.app does not appear to be a valid OS installer application.

--volume /Volumes/julius sudo: /Applications/Install macOS Ventura.app/Contents/Resources/createinstallmedia: command not found

Downloading a full install through CLI works perfectly.

Thank you

softwareupdate --list-full-installer softwareupdate --fetch-full-installer --full-installer-version 12.5

2
  • 2
    Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. - From Review
    – agarza
    May 16, 2023 at 19:33
  • 2
    It appears you took info from two separate answers to solve your problem; that’s great news! However, please don’t write a “Thank You post” instead, up vote the appropriate answer(s) and leave a comment if you need further clarification or want to add some details.
    – Allan
    May 16, 2023 at 20:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .