I use Due for reminders, and have it set up to use the keyboard shortcut Cmd+Opt+D to activate the Due window (which lives only in the Menu Bar, not the Dock). This works fine in most applications and on Big Sur it worked fine everywhere, but after a clean install of Monterey it seems that Terminal.app is at least partially eating this shortrcut.

If I do the following with Due initially deactivated:

  1. Cmd+Tab to Chrome or TextMate or anything else.
  2. Press Cmd+Opt+D repeatedly.

then the Due window will come and go as expected, getting keyboard focus each time. But if I do the same with Terminal.app in step (1) then the Due window shows up after the first Cmd+Opt+D, but without keyboard focus, and will not disappear again later. It never becomes the active window.

In fact, the symptom is even more general. If Terminal.app is active and I use Spotlight to open System Preferences, System Preferences opens behind Terminal.app, without keyboard focus. No other app causes this symptom.

How do I get Apple Terminal or Iterm to not interfere with Due starting from the keyboard shortcut?

1 Answer 1


It turns out this was due to the Secure Keyboard Entry setting in the Terminal menu:

Terminal menu showing "Secure Keyboard Entry" checked

Turning that off fixes the problem.

  • This was the same case for me when using iTerm
    – DBrown
    Jul 5, 2022 at 21:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .