1

This has been bothering me for months. Basically, when I type, it takes a lot of milliseconds for the key presses to register on the screen. This affects web browsing, coding (e.g. Sublime Text), and possibly most annoying, terminal (e.g. doing important, destructive operations and not being sure if 'enter' has registered - anxiety inducing and shouldn't happen).

I've bene searching on and off for solutions to this for a few months. Any ideas how to fix it?

What I tried

I tried resetting the SMC but unfortunately it made absolutely no difference.

1 Answer 1

0

After months of enduring this, I found the answer deep in a thread.

Go to System Preferences -> Battery -> UNTICK 'Automatic Graphics Switching'

enter image description here

The lag/sluggishness/jankiness immediately stops!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .