1

I have a Mac Mini (Mid-2011 model), running Mac OS X 10.11.6, with iMovie 10.1.6.

I have a iMovie Library.imovielibrary file in the ~/Movies folder, which contains all my iMovie projects.

When I don't have iMovie running, and I perform a Time Machine backup, Time Machine backs up the file just fine.

However, when I have iMovie running, Time Machine does not back up the file. For some reason, Time Machine believes the iMovie Library file has been deleted, while iMovie remains open. And then when I quit iMovie, Time Machine backs up the iMovie Library file again, since it is then able to "see" the iMovie Library again, even though it never went anywhere.

And since Time Machine thought the iMovie Library was deleted, then later sees it, it thinks that the iMovie Library is new, so it backs the whole thing up, rather than only the changes that were made since the last iMovie Library backup.

So, why does Time Machine believe that the iMovie Library is deleted while iMovie is open, and how can I fix it? I've already tried running First Aid on my internal drive, but that didn't fix it.

5
  • What evidence do you have that TM thinks the file is not there?
    – Tetsujin
    Apr 2 at 16:42
  • @Tetsujin In BackupLoupe, it shows that the iMovie Library file is created in one backup, then deleted in the next, then created in the next, then deleted in the next, etc. Also, when stepping through the folder containing the iMovie Library file in Time Machine, the file exists in one backup, then not the next, then it appears in the next, etc.
    – Gary
    Apr 2 at 19:20
  • I've never tried BackupLoupe. There's always the possibility that's it's not interpreting the data in the same way your are, but I've no way to check.
    – Tetsujin
    Apr 3 at 13:39
  • @Tetsujin Ignoring BackupLoupe for a moment, when I step through the ~/Movies folder in Time Machine, I see that the iMovie Library appears in one backup, then in the subsequent one it does not appear, then in the next one it appears, then in the next one it disappears. In addition, Time Machine backs up the entire 150 GB iMovie Library every other backup, so clearly it's not making incremental changes, since it's not like I have modified every single one of my projects in iMovie.
    – Gary
    Apr 3 at 15:25
  • You're not supposed to dig inside every folder. Look in Latest. Anyway, I can't see what you're seeing, so I can't say any more than I did.
    – Tetsujin
    Apr 3 at 15:36

1 Answer 1

0

This is normal and expected behaviour. The .imovielibrary file is a dynamic object, being read and written to almost constantly when iMovie is in use.

If Time Machine were to backup an open .imovielibrary file, (which can be very large in size,) the first half of the file may have changed by the time the second half of the file has been backed up. That is logically inconsistent, as it is not a true replication of the file!

Because the backup process can only realistically be successful on a static file, Time Machine does not back it up.

Does this make sense?

Although tangental to this question, this question/answer has some interesting info you might fine useful.

1
  • Time Machine views the iMovie Library file as if it has been deleted, when I have iMovie opened. So when I close iMovie, and Time Machine sees the file again, it backs up the whole thing in its entirety, because it had previously deleted the copy in Time Machine. This is not normal behavior. Normal behavior is identifying no changes in the iMovie Library while iMovie is running, rather than believing that the iMovie Library has been deleted, which is what I'm currently experiencing. I've edited the original post to hopefully be more clear.
    – Gary
    Apr 2 at 2:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .