0

Using a Macbook Pro, 2015, system 10.14, I have an external harddrive and when I plug it into my laptop the folders will show up in the Finder but not the files. But this only happens some of the time. Usually what happens is the topmost folders will appear and yes, the files that are topmost, and then when you click on the folders nothing appears inside of them even though there are subfolders within them. I've tried repairing the disk with disk utility but I got the following error message: First Aid could not unmount the disk. Also when I try to view the files and open them with terminal, that also does not work.

Also, if I cannot solve this problem myself, do you recommend sending my harddrive to a company that specializes in data recovery?

#######UPDATE

here is what happens when I hit cntrl-I. Oddly enough one of the drives has the box ticked for 'ignore ownership' but the other does not. Both disks have the same problem. The backup disk though is the more important one. Also, this was the first time this has happened but now when I connect that disk to my laptop it also messes with the file system of my laptop. I can now no longer see what's inside of folders on my laptop when I plus that drive in. I have to restart my computer in order to get it working again.

enter image description here

4
  • Get Info (Command-I) on the drive. At the bottom of the Get Info window, is the "Ignore ownership on this volume" checked or unchecked?
    – IconDaemon
    Mar 31, 2022 at 17:44
  • 1
    On the drive itself, not the Backups.backupdb folder which is in the drive.
    – IconDaemon
    Mar 31, 2022 at 19:25
  • see update .....
    – bobsmith76
    Apr 2, 2022 at 1:42
  • 1
    You have to switch off Time Machine to use Disk Utility on it. You cannot ignore ownership on a TM drive. A very full TM drive can take a long time to view folder contents - it has to figure out all the links.
    – Tetsujin
    Apr 2, 2022 at 9:23

1 Answer 1

0

Problem solved. I had instructed Time Machine to not link to any disk. I then relinked it to the disfunctional disk and that enabled me to read the files again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .