I have a CSV file that I open in Numbers, I need one of the cells to be a URL clickable link though, and in the CSV file if I use something like this, it does not turn into a clickable link in Numbers:


If I type in the above in a cell in the Numbers app, then it automatically turns into a clickable link with the words "Apple".

I am guessing if Numbers opens a CSV file, it does not support functions such as =HYPERLINK. Perhaps it has to be a Numbers formatted file for it to support functions?

Is there a way to "ask" Numbers to open a CSV file in Numbers format so that it can understand the HYPERLINK function?

  • What exactly happens when you open the text file containing only =HYPERLINK("https://www.apple.com","Apple") as text with Numbers? What happens when you open another text file with only the formula for text such as =5+2 with Numbers again?
    – Alper
    Commented Mar 31, 2022 at 10:35
  • If I open the CSV containing =HYPERLINK("apple.com","Apple"), I see the cell contents as just that, =HYPERLINK("apple.com","Apple"). If I enter =5+2 in the CSV file, then I see 7 when Numbers opens it up. Commented Mar 31, 2022 at 16:49
  • I think I figured it out =HYPERLINK has a ',' in it, between the URL and the text, and since this is a CSV, Numbers is using that comma to create another cell, which is screwing up the HYPERLINK function understanding by Numbers. I need to perhaps convert the CSV to some "other" format. Commented Mar 31, 2022 at 16:56

1 Answer 1


You can (partially) resolve this problem by telling Numbers how to interpret a text file right after the file is opened by Numbers as also described in the "Import an Excel or text file into Numbers on Mac" Apple Numbers support webpage. I call this a partial solution because it requires the manual intervention described below every time you open the text file with Numbers.

When Numbers opens a text file, it automatically breaks down each line into separate cells based on the default delimiter such as a comma. You can change the delimiter or have Numbers assume there are no delimiters within a line using the options in the "Import Settings" window. You can get to that window either through the pop-up window that appears right after a text file is opened (first picture below) or through the Format > Table > Adjust Import Settings sidebar menu option (second picture below). Note that the pop-up window opening right after the text file is opened disappears after a few seconds and the one available through the sidebar also disappears once you make any changes to the opened file.

enter image description here enter image description here

After getting into the Import Settings window, click on the delimiter selected by default (default delimiter is comma if your macOS regional settings are set as US or UK) to deselect it and then click on Update Table as shown in the GIF below.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .