2

I just got a desktop notification on my MacBook that seems like spam. This is remarkable because I've never got a notification from anything other than my macOS notification before. I don't use non-OS notifications and don't want them.

Viewing in messages it is a "stock tip" in a foreign language and says:

iMessage with xxxxx@hotmail.com

where "xxxxxx" is a placeholder.

A few months ago I'd sent a single iMessage by accident on my iPhone (not my laptop), I'd forgotten to turn it off after getting a new iPhone. I don't want to debate my personal preferences here, but I would like to know if turning off iMessage is the only way to block spam notifications like this. (I will turn of iMessage irregardless)

notes:

  1. I have BlueTooth turned on because of my Apple Watch and my phone is also connected via USB to my laptop for hotspotting.
  2. The message shows up in Messages on my iPhone as well, but for some reason there was no new message notification that I could see in the phone.
  3. I do not have iMessages on my laptop (as far as I know)
  4. iOS 15.3.1 and macOS 10.15.7

For background:

7
  • 1
    An iMessage doesn't have to be sent to a phone#, it can be sent to an email address. You can check your "to be reached at" IDs in iMessage preferences, in the iMessage tab, and maybe adjust these to avoid the spam.
    – Scot
    Mar 31 at 1:37
  • @Scot you mean iMessage tab on my phone correct? As mentioned in item #3 I don't have the iMessages app on my laptop as far as I can tell, which is one of the reasons that I was surprised to get a notification on my laptop. I did have gmail open in a tab of my Chrome browser on my laptop at the time, but I don't think that could be related (I'll add that to the question)
    – uhoh
    Mar 31 at 1:43
  • 1
    This message may not have been sent to your phone, or your desktop, but instead to an email address. In any case - you can turn off notifications from unknown contacts in the General tab in Message Preferences within Messages on your Mac. Presumably the spam is from people who are not in your contact list.
    – Scot
    Mar 31 at 1:58
  • 1
    @Scot It shows up in messages on my phone as well and does not appear in my Apple ID-associated email inbox nor spam folder, so I will guess that it was sent to my phone number. My one accidental iMessage was sent to someone who will have lots of international connections and may have very bad security hygiene so I'm gonna guess that that's the origin. Here's what I have now: i.stack.imgur.com/dNkE7.png I've just turned off "enable this account" but not sure if that's the right thing to do. You are more than welcome to post as an answer rather than another comment. Thanks!
    – uhoh
    Mar 31 at 2:10
  • 1
    Done. Hopefully that is helpful for you... I think the method you used shown in the picture should also eradicate the spam, but you will see!
    – Scot
    Mar 31 at 2:20

1 Answer 1

2

If you would like to turn off all notifications for Messages.app, you can do so in System Preferences - Notifications & Focus - Messages. Turn off "Allow Notifications."

Your phone may have nothing to do with this - one can send an iMessage (which is distinct from an EMail) to an Email address. You can check the locations that Messages.app (on your Mac) is "listening" on within Messages.app preferences, in the iMessage tab, and adjust these as needed to help stop the spam messages from coming through.

1
  • Yes this is exactly what I needed to know.
    – uhoh
    Mar 31 at 2:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .