1

I've been trying to fix this issue for the past week or so. Some sort of boot issue seems to occur once a year on this machine, and I will be upgrading but need this one to hold on a little longer.

First, I'm over explaining things here because I've tried so many things and I cant pinpoint an exact issue.

Pressing the power button, I get the POST noise, the apple, and a loading bar. After about 2 minutes of it loading, the screen goes black, and it shuts off. I dual boot Kali Linux with full root permissions (rwx on all partitions/containers), but I have been careful to not make any changes to the osx filesystem. When this first happened, I hadnt made any changes in either OS, It was sleeping, and then I noticed it was off.

I first tried holding the option key down for the boot options, It showed: EFI Boot(Kali), Skylake(OSX), Install Mac OSX(it said something like this but I had never seen it before), and Recovery HD. I was thinking maybe it was updating and the update failed and fudged up the boot info.. so I booted the online recovery mode. Ran first aid on the drive and it failed. Initially because it couldnt be unmounted. When it did unmount it still failed first aid for anything in an APFS container.. So I booted into kali linux, found some weird log message saying there was a failed install on OSX, and then back in Recovery mode I could get it to populate and it gave me an option to revert changes. I chose yes. Now the "Install Mac OSX" option is gone from the boot menu but it still shuts off during boot and no other options or questions I've found in the forums so far have worked to my advantage. I'm at a loss, I have included pictures for some of the basic things, let me know if I can run something else. I'm not as well versed with OSX diag and terminal commands like I am with linux, but I've never had to work this hard on an issue for this computer before.

I think the boot partition is corrupted but attempting those fixes never bore results. When booting into recovery mode it always said "Install" instead of "Reinstall" so even the recovery drive could not recognize the filesystem. I ran a few other checks on the file structure and I after a few attempts, I DID get the online recovery to see the filesystem to see the "Reinstall" option. That ran for about 3 hours and came back with a log error that it couldnt reboot itself and it was in the middle of trying to force a reboot. After about two minutes of no other changes to the log, it did reboot. but then came up with the same file system error that first aid was giving.

I'm at a loss, I've included pics of some basic commands, the log after running first aid, and one of the reinstall failures.

Please help

Failed reinstall diskutil list some outputs from gpt -r show Info on the boot 'partition' in the APFS container Log from First Aid failure

1 Answer 1

1

So I've not been able to get it repaired, and since I've not received any comments, I went forward with a format and reinstall. I needed to pull the data off though, so I booted into my Linux build and ran the following command:

sudo apt install libfsapfs-utils

I plugged in my backup drive and then switched to the root account for the next steps. I ran the following command to get the volume info

sudo fdisk -l
sudo fsapfsmount -f 1 [device/container] [mount point]

The device being /dev/sda2 and the mount point being /media/root

For the mount point, I couldn't get it to mount to root without needing an exception so I used my 2nd user profile as the mount point while logged in as root. For me it was:

sudo fsapfsmount -f 1 /dev/sda2 /media/kali

I then copied over all my data to my backup drive. And used g parted to wipe and partition the drive as needed for my reinstall. Which then worked without an issue

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .