I have the original 2010 iPad 3G, and when I purchased it I also got a SIM card for Rogers 3G data service here in Canada.

Can I simply remove the 3G SIM card from my original 2010 iPad, and insert it into my new 2012 iPad when it arrives? i.e. is it compatible and will my data plan continue to operate as before, but on the new iPad?

Then, even if it is compatible, is there an advantage to getting a new SIM card? Are there data features for the new iPad (e.g. higher speed?) only enabled by a new SIM card?


This will depend largely on your carrier. If they're offering 4G/LTE service with the iPad 3, you may need a new SIM card. If they're not offering that service in your area, it shouldn't matter if you have a new SIM card or not. Your best bet is to ask your carrier.

  • 1
    You're right. I got my hands on my new iPad (2012) later this afternoon, and after I had set it up and synced, I powered it down and tried the SIM card switch. While the SIM card from my old iPad physically fit the new one, it didn't work ("No Service"). I called Rogers (my data provider here in Canada) and the rep said I need to get a new SIM card, from my local Rogers store -- specifically, a LTE-compatible post-paid micro SIM card, then call them to move my iPad account to the new card. – Chris W. Rea Mar 16 '12 at 20:55
  • 1
    For what it's worth, I could have asked Apple to ship me a Rogers SIM card with the new iPad, but I thought I had a good one already. Besides, the rep from Rogers said that would have been a pre-activated card, but since I have a data-sharing plan with my iPhone, I need to tie my iPad SIM back to the same account, hence the "post-paid" kind of card I mentioned above. – Chris W. Rea Mar 16 '12 at 20:57

The Apple website states you need a:

Micro-SIM card tray

Same as the iPad 2. So I'm pretty sure the cards have the two dimensions. Otherwise their would have been some complaints about not fitting the SIMcard.

  • The 3G card from the iPad 2010 is a match on the form-factor, but it unfortunately doesn't work in my new iPad 2012 .. I just tried. "No Service". This might be carrier-specific (I'm on Rogers, in Canada) so to others, YMMV. – Chris W. Rea Mar 16 '12 at 20:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .