I have a MacBook Pro 16" (2021) with the M1 chip. I connect my old Thunderbolt Display with the Apple USB-C to Thunderbolt adapter. The display works fine, and I can connect devices to its ports which work great, but when the computer is connected, USB devices plugged into the display are not charged. I noticed this with my iPad Pro 11", which refuses to charge from USB.

The strange thing is, that I know that TBD is able to charge my iPad, since it always worked with my previous Intel Mac (still works), and when the M1 MBP is not connected.

Is there any workaround for this issue? Is this only my device or is this a bug?

M1 MBP not connected: M1 MBP not connected

M1 MBP connected: M1 MBP connected

Update: measurements

  • TB Display uses USB 2, so it can only charge at 2.5W. But I'm not convinced that the type of computer should be a factor. First of all, you need to pinpoint the problem. Is it every attached device? Does it matter if you use a different port? Can you try a different cable? What does System Information say about the USB devices attached?
    – benwiggy
    Mar 23, 2022 at 16:33
  • I did the basic cross-checks: true for all ports on the display, true for all devices. Cable doesn't matter. Devices seem to get only 500 mA according to System Profiler.
    – gklka
    Mar 23, 2022 at 17:23
  • Is it only your iPad? What model and year is it? Can you test with other devices - a phone?
    – benwiggy
    Mar 23, 2022 at 17:35
  • Not only my iPad, but iPad Pro 11" (2020) is one of the devices which require higher currents, it is hard to tell if other devices suffer too, because they charge but only with the standard USB 500 mA. iPad charges when nothing is connected too. Obviously I can't tell the mAs this way. When I connect my previous laptop (MacBook Pro 15" 2019) to the display, everything works fine, iPad charges, and I can see the higher currents in System Profiler.
    – gklka
    Mar 23, 2022 at 21:06
  • What about if no computer is plugged in?
    – benwiggy
    Mar 23, 2022 at 22:34

3 Answers 3


[Not an answer, but I wanted to share more data and don't have the reputation to comment. Apologies.]

I'm seeing exactly the same issues – all worked fine with my old Intel MacBook, but my M1 Pro seems to prevent the power negotiation step of the connection happening. Oddly I also see this with a USB light (only charges from the TB Display when the MBP isn't connected), but my audio interface and Android phones draw power fine from the USB-A connection. System Profiler suggests that the iPad requires & is receiving 500 mA, which is enough to charge it where the MBP isn't connected to the display. Directly connecting the iPad to the MBP via a USB-C to A adapter (with the same cable) works fine.

On the iPad specifically – I just updated to iOS 15.5, and interestingly following the update the iPad was charging fine. However, as soon as I pulled and re-plugged the connection to my Thunderbolt Display, it went back to 'Not charging'. Restarting the iPad while connected to the display doesn't give the same result.

Setup: M1 Pro MBP 16" > Apple USB-C to Thunderbolt adapter > 27" Thunderbolt display > USB-A to C cable > iPad Air 4 (2020). All up to date at time of writing.

  • 2
    Super details - can you confirm the comment above that shutting down the M1 Mac then allows the same setup to charge? (I.e. the implication is when running the change happens for the detriment to charging)
    – bmike
    May 26, 2022 at 9:34
  • Yeah, just tried it, and while the M1 is off the TB Display charges the iPad. As the SMC starts up, and the Mac gets beyond firmware into the OS, it goes through the standard connection cycling, but by the time I'm being asked for a username and password the iPad shows 'Not Charging'. May 27, 2022 at 18:26
  • I just plugged my old Intel MacBook in and compared like-for-like in system profiler. The key difference I can see lies in 'Extra operating current' – the Intel Mac shows 1600mA, while the M1 shows 0. Do I understand this correctly that the M1 won't allow a USB2 port on a TB2 hub to provide any more than 500mA, while the Intel will let the hub distribute what it has available? May 27, 2022 at 18:57
  • Yes, it seem so.
    – gklka
    Jun 1, 2022 at 16:04

It seems, that macOS Ventura 13.0.1 fixed the issue. iPad is charging fine for me now.


I don’t have a solution but I can confirm the experience of the OP and others. I don’t have the means to measure the output current from the TB Display USB ports so can only observe the effect on iPad charging. Issue occurs across a range of iPad models (12.9” iPad Pro 2nd gen (2017), 12.9” iPad Pro 5th gen (M1), and iPad 6). IPhone 13 Mini charges normally. Portable USB drives connected to TB Display also function normally.

Issue occurs only with M1 MacBook Pro (running Monterey) connected to TB Display. Does not occur with Intel MBP 2012 running Big Sur nor with 2019 Intel MBP running Monterey. Does not occur with no computer connected to TB Display. Does not occur with iPad connected directly to M1 MBP (via USB-C to USB-A adapter and Lightning cable.

So it seems that M1 MBP <-> TB Display is necessary and sufficient to cause this issue.

I submitted a bug report to Apple a few months ago and hoped in vain that a Monterey update would fix the issue.

Does anyone know if the issue has been fixed in Ventura? (I don’t want to update this soon on my only AS machine!)

  • No, Ventura did not change this.
    – gklka
    Oct 27, 2022 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .