I've tried as much as I can find, anything with diskutil in the terminal or in the GUI hasn't worked. Asahi doesn't show up in the GUI or in the boot options now. I want to completely erase all the data associated with Asahi and give it all back to my main "Macintosh HD" drive

(Note that my ssd is 256Gb) GUI Diskutility

Output of diskutil list

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         251.0 GB   disk0
   1:             Apple_APFS_ISC ⁨⁩                        524.3 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk4⁩         170.0 GB   disk0s2
   3:                 Apple_APFS ⁨Container disk1⁩         2.5 GB     disk0s3
   4:                        EFI ⁨EFI - ASAHI⁩             500.2 MB   disk0s4
                    (free space)                         72.1 GB    -
   5:        Apple_APFS_Recovery ⁨⁩                        5.4 GB     disk0s6

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +2.5 GB     disk1
                                 Physical Store disk0s3

/dev/disk4 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +170.0 GB   disk4
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Macintosh HD⁩            15.2 GB    disk4s1
   2:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.2 GB    disk4s1s1
   3:                APFS Volume ⁨Preboot⁩                 590.1 MB   disk4s2
   4:                APFS Volume ⁨Recovery⁩                798.2 MB   disk4s3
   5:                APFS Volume ⁨Data⁩                    71.5 GB    disk4s5
   6:                APFS Volume ⁨VM⁩                      1.1 GB     disk4s6

Any help would be appreciated.

Update: I've done something that made my asahi partition called (free space) in the updated diskutil list output above and it doesn't have a point on my ssd but this isn't allocated in Macintosh HD and looks weird in the GUI. It's only got 170GB when it's a 256Gb Hard drive - The pie chart doesn't count the full 256Gb, only 170GB The pie chart doesn't count the full 256Gb, only 170GB

It seems like the partition drive only shows this container's space.

Edit: More weird stuff. It says my SSD is 251GB, which it is but the partitions added together don't count as 251GB, only 170... Even though I have "Show all devices" checked in the menu bar for disk utility Read above


2 Answers 2


Update: The Asahi folks have written up a guide to cleaning up after their changes, and indicated that they will provide a built-in way to do it in the future: https://github.com/AsahiLinux/docs/wiki/Partitioning-cheatsheet

It explains a lot of the reasoning, and also provides a command to resize the container with diskutil as well.

Your disk is fine, to remove Asahi linux you can use these commands. PLEASE check the disk numbers, since I've written them based on your diskutil output, but if it's changed please use the numbers it shows now, not what I've written below.

To delete a partition and replace it with free space:

diskutil eraseVolume free free /dev/disk#s# (I believe disk0s4 is what you want here, for "EFI - ASAHI⁩")

If the partition is an APFS container, use this command instead, referencing the synthesized disk number instead:

diskutil apfs deleteContainer /dev/disk# (I believe disk1 is what you want here, for the 2.5GB container not your main container)

Once you've done this, you should just have:

/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         251.0 GB   disk0
   1:             Apple_APFS_ISC ⁨⁩                        524.3 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk3⁩         245.1 GB   disk0s2
   3:        Apple_APFS_Recovery ⁨⁩                        5.4 GB     disk0s3

(With free space likely appearing between disk0s2 and disk0s3 in this example)

To grow the container to use the free space, you can do this in Disk Utility UI. I found it was a little funky but after clicking around it eventually let me resize it.

  • Thanks but /dev/disk4 Started APFS operation on disk4 Deleting APFS Container with all of its APFS Volumes Unmounting Volumes Unmounting Volume "Macintosh HD" on disk4s1 Unmounting Volume "Preboot" on disk4s2 The volume "Preboot" on disk4s2 couldn't be unmounted because it is in use by process 0 (kernel) Error: -69888: Couldn't unmount disk... :( IDK what's causing this :(
    – Piboy314
    Mar 23, 2022 at 17:38
  • @Piboy314 disk4 is your regular macos disk, don't delete that ... when you run diskutil list you should have one that looks like: /dev/disk1 (synthesized): 0: APFS Container Scheme - +2.5 GB disk1 That's the one (disk1) you want to delete
    – Ezekiel
    Mar 23, 2022 at 18:40
  • 1
    (Also, please for the love of all that is holy, make sure you have a full backup of your files before you do anything—ideally also make sure that's done before you install any alpha software that changes the partitioning of your main drive!) Mar 23, 2022 at 21:53
  • 1
    Thank you so much! I forgot it was disk1 that I should delete lmao. After doing that I went into the Disk Utility GUI and fixed it :D thx so much!
    – Piboy314
    Mar 23, 2022 at 22:01

Thank GOD! For me help - diskutil eraseVolume free free /dev/disk#s# then via Utility GUI merging disk to main

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .