66

I'm getting the following errors when launching my terminal, seemingly out of nowhere. I have no idea what the cause is.

2022-03-23 09:41:00.818 xcodebuild[2352:21059] Requested but did not find extension point with identifier Xcode.IDEKit.ExtensionSentinelHostApplications for extension Xcode.DebuggerFoundation.AppExtensionHosts.watchOS of plug-in com.apple.dt.IDEWatchSupportCore

2022-03-23 09:41:00.818 xcodebuild[2352:21059] Requested but did not find extension point with identifier Xcode.IDEKit.ExtensionPointIdentifierToBundleIdentifier for extension Xcode.DebuggerFoundation.AppExtensionToBundleIdentifierMap.watchOS of plug-in com.apple.dt.IDEWatchSupportCore

Does anybody know how I can go about fixing this please?

5
  • What is your default shell and what is in your shell startup files?
    – mmmmmm
    Mar 23 at 9:53
  • 1
    I have somilar messages now and then. Sometimes it helps to rerun xcode-select.
    – nohillside
    Mar 23 at 10:42
  • I'm having the same error Today for the first time ever. And I use the Iterm2 terminal almost every single day. Apr 4 at 12:27
  • @nohillside I have this message every first run of my terminal. And no, xcode-select definitely does NOT solve it.
    – sovemp
    Apr 8 at 23:24
  • installing new macOS 12.4, resolved my issue. May 17 at 16:18

6 Answers 6

18

This happens with XCode after every upgrade.

So, like @Eljay, I placed the following commands in a script, upgrade-xcode-cli-tools, which I call after each XCode upgrade:

#!/usr/bin/env bash

# remove old CommandLineTools
# to force upgrade
sudo rm -rf /Library/Developer/CommandLineTools

# install latest
sudo xcode-select --install

Note that the script will cause a pop-up that requires user participation (e.g. accepting EULA). I am not aware of any way around this.

1
  • 1
    Warning: The install this requires is extremely slow (~3 hours on a 15mb/s connection). Make sure you can wait. Jul 20 at 17:20
49

Neither "installing components" via Xcode, nor resetting the developer directory using sudo xcode-select -r worked for me. However,

sudo xcode-select -s /Library/Developer/CommandLineTools

worked. Thanks to Royite on Apple's Developer Forums for this solution.

4
  • 2
    this worked for me, for Xcode 13.3 macOS 12.2.1 (21D62), iterm2
    – Sajjon
    Apr 6 at 12:36
  • 3
    I had to sudo rm -rf /Library/Developer/CommandLineTools then sudo xcode-select --install, and that fixed the issue for me. (Got the recommendation hint from brew doctor.)
    – Eljay
    Apr 9 at 14:32
  • After I did this, I could no longer run xcrun xcodebuild from the command line. brew doctor says everything is fine. However, terminal and most command line tools run fine (thanks to sudo xcode-select -r). However xcrun xcodebuild generates both this error and another about "Class ... is implemented in both ...".
    – mm2001
    Apr 23 at 5:25
  • worked for me, Xcode command line tools on macOS v12.3.1
    – cenk
    Apr 29 at 14:23
16

This happened to me after an Xcode version update. Running XCode app and letting it re-install components resolved the issue.

2
  • 1
    What do you mean by "letting it re-install components?" Did this happen automatically, or did you have to select a menu item or otherwise trigger it? Mar 31 at 21:27
  • 2
    Should happen automatically when running XCode first time after update. (Unless XCode is somehow "stuck")
    – Jas
    Apr 1 at 22:12
6

Solution:

  1. Close the terminal (it was Iterm2 in my case).
  2. Just open Xcode.
  3. It will request to instal additional components. Press on 'Install'.
  4. When it ends, close XCode.
  5. Open the terminal again. No more error messages.
2

Running each one of these commands twice fixed it for me. This outputs your current sdk paths.

The errors appear on the first run, and after the second run, they magically disappear for good.

xcrun -sdk iphoneos --show-sdk-path
xcrun -sdk iphoneos --show-sdk-version
xcrun -sdk iphoneos --show-sdk-build-version
xcrun -sdk iphoneos --show-sdk-platform-path
xcrun -sdk iphoneos --show-sdk-platform-version
xcrun -sdk macosx --show-sdk-path
xcrun -sdk macosx --show-sdk-version
xcrun -sdk macosx --show-sdk-build-version
xcrun -sdk macosx --show-sdk-platform-path
xcrun -sdk macosx --show-sdk-platform-version
xcrun -sdk watchos --show-sdk-path
xcrun -sdk watchos --show-sdk-version
xcrun -sdk watchos --show-sdk-build-version
xcrun -sdk watchos --show-sdk-platform-path
xcrun -sdk watchos --show-sdk-platform-version

Source: https://stackoverflow.com/questions/71320584/flutter-build-ios-got-error-requested-but-did-not-find-extension-point-with-ide

-1

The easy solution is if you are building react native app. just run the command below.

react-native run-ios

1
  • The question is about Xcode errors in Terminal. Can you explain how the command you propose solves those?
    – nohillside
    Jun 6 at 7:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .