1

This morning after Time Machine did its usual backup, I decided to to the update to macOS 12.3 on my MacBook Pro 13” 2020 (no repairs have been done on this unit). System Update downloaded the installer and began the process of updating my system.

After a reboot, the Mac rebooted with the big Apple on the screen with the progress bar underneath. I noticed that the progress bar was at the same point for over half an hour so I opted to reboot the Mac. Big Apple appears with progress bar and as before it stops at about 20% in.

I reset the SMC, same as before. I booted into Recovery Mode and checked the disk for errors. There were several errors related to Time Machine snapshots. I tried repairing several times with the same results.

I decided to reinstall Monterey. The laptop starts the download and proceeds to do the installation. Upon the reboot, I get the Big Apple with progress bar but now it stops at about 90%. I tried to reinstall Monterey twice with the same results. I went back into Disk Utility to run First Aid and there were no longer any errors.

At this point, I am guessing that I need to format the drive, install Monterey, and restore from backup (thank goodness I have one).

Am I at the right conclusion? Is there anything else that I can do before doing a format/reinstall? If I do have to format, which partition do I erase the one labeled “MacBook” or “Macintosh - Data”?

3
  • 1
    What exact model of Mac do you have? And did the system ever have its original logic board replaced during a service visit?
    – pion
    Mar 23 at 4:25
  • 1
    This is a MBP 13” 2020 with no repairs.
    – agarza
    Mar 23 at 12:59
  • You may be able to restore time machine directly, no need to format. However, if you need to format, use the Apple menu in the Recovery mode that has Erase all contents and settings
    – Ezekiel
    Mar 23 at 17:01

1 Answer 1

0

So, I ended up calling Apple Support to make sure I didn't screw things up royally.

I was on the right track; the Apple Support person did say that I would have to format the drive. She said that I would need to reboot into Internet Recovery Mode (Cmd+Opt+R) in order to do it properly. Booting into Internet Recovery Mode took about 30 mins.

The technician then instructed me to run Disk Utility, select the internal drive (this selects all the volumes), and click Erase at the top of the window. She recommended running First Aid after erasing to make sure there were no errors (there were none).

Next, I was directed to quit Disk Utility and select Reinstall macOS Monterey. This would take a while but would download and install a fresh copy of macOS 12.3.

After the install and reboots, I was greeted with the new OS and proceeded to answer the few questions then migrated my data from my backup drive.

I received an email from Apple Support with the steps from the following links:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .