30

For some reason I'm unable to share a window or full screen on Chrome with Google Meet on Mac. Versions:

  • Chrome: Version 99.0.4844.74 (Official Build) (x86_64)
  • Mac: Monterey 12.3

In the Mac settings under security, screen recording is enabled for Chrome. I've tried restarting Chrome, restarting the computer, disabling and enabling screen recording for Chrome from the settings (with Chrome restarts in between) but nothing seems to work. The screen sharing also doesn't work for google meet (the app).

enter image description here enter image description here

3
  • 3
    Have you tried removing, then re-adding, Chrome to the list of apps? This question/answer may have some answers.
    – IconDaemon
    Mar 17, 2022 at 11:03
  • 1
    Removing and adding it back does not solve the problem, nor reinstall. This specific version has an issue. Mar 20, 2022 at 10:38
  • Removing and adding it again worked for me, thanks! Jun 21, 2022 at 16:09

4 Answers 4

35

If the recent google updates to 99.0.4844.83 (Official Build) don’t fix this bug for you, here is a repair workaround for the changes made to the app:

  1. Quit Chrome
  2. tccutil reset ScreenCapture com.google.Chrome in Terminal

Manually added Chrome:

  1. Open System Preferences > Security & Privacy > Privacy Tab > Screen Recording (option on lefthand side)
  2. Click the lock at the bottom to make changes
  3. Click the + and add /Applications/Google Chrome

Relaunch Chrome.

6
  • I ran into the exact same issue with the exact same Browser and MacOS versions. I was wondering if maybe it was a known issue in Chrome and they had a fix in an upcoming version, so I downloaded the Chrome Beta version (Version 100.0.4896.45 (Official Build) beta (x86_64)) and it worked for me. Very strange. Mar 17, 2022 at 18:55
  • We experienced the same issue and the Beta version did work! Mar 19, 2022 at 19:37
  • Yes! Confirmed this works. Mar 22, 2022 at 7:55
  • 2
    This works! BLESS YOU!
    – EvilJordan
    Mar 22, 2022 at 15:46
  • Using the beta version (100.0.4896.45) also worked for me - thanks for the suggestion! Normal Chrome was version 99.0.4844.83 (latest update). These are two different apps, so it's possible "normal" Chrome has some corrupt files somewhere that are causing this issue.
    – bjt38
    Mar 24, 2022 at 9:22
2

Had the same issue but updated to the latest version of Chrome (99.0.4844.83 (Official Build) (arm64)) and issue gone

0

Login to google accout in Safari browser and then try to share screen on Google meet. It will work. It has an issue with Google Chrome in Mac.

5
  • Interesting... I have the exact opposite experience. I have to use Chrome when using Google Meet (Chrome 99.0.4844.51 (Official Build) (arm64)) (same Chrome 99.... version on my Intel Mac.) Safari will join a meeting but my audio and video are all horked up. Chrome is the only browser Have found on a Mac that works fully with Google Meet. Mar 17, 2022 at 17:26
  • @TheWellington Did you try to share screen or window on Google meet in Google Chrome? Mar 17, 2022 at 18:04
  • 1
    Yes. I use screen share daily, and have used window sharing occasionally Mar 17, 2022 at 19:55
  • Then it might have an issue, in particular, the Google Chrome version only. I Hope Chrome will resolve in an upcoming release. Mar 18, 2022 at 16:44
  • Do you know how to share a tab or a specific window only (as opposed to entire screen) with Google Meet in Safari?
    – a06e
    Sep 2, 2022 at 8:34
0

I can confirm this behavior. It Version 99.0.4844.74 (Official Build) (arm64) and it still there. Unfortunately, from Safari you cannot share a "window" from another application. So, I have to go to Firefox to get this option.

It doesn't work in Chrome. The problem became consistant after the last OS update. Prior this, it was erratic (a complete restart of the computer OR a "Force Quit") of google chrome did the job. Now, Chrome is unable to share windows altogether.

3
  • The .83 minor minor minor version update should fix this without needing the workaround / repair.
    – bmike
    Mar 23, 2022 at 9:33
  • I just updated .83 right now and I can confirm that this fixes the issue! Great discovery Mar 24, 2022 at 10:46
  • 1
    Confirming that .83 does not fix it for me.
    – FGM
    Mar 25, 2022 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .