1

Every night, my wife closes the lid on her M1 MacBook Air (currently running Monterey 12.2.1) before she goes to bed. About one in three times, it's completely frozen (black screen) when she opens it in the morning, and she has to force reboot it.

Nothing is plugged into her laptop except the power cord. I've had her leave it unplugged overnight to see if it makes any difference, but it still happens some nights and not others. I've also had her leave the lid open, but that doesn't alter the frequency of the hangs either.

I've looked at system.log and friends, but to no avail. To my relatively untrained eye the logs look normal until the system freezes, then there's a gap of a few hours until the manual reboot begins. I've also run the system diagnostics at boot, which found no issues.

Since it was initially set up from an x86 SuperDuper clone of a system that was itself upgraded in-place for a decade, my totally random guess is that maybe there's some crufty old x86 app or process that just isn't playing nicely with Rosetta. But that's based on nothing other than the fact that there's no obvious hardware culprit.

Are there any specific logs or messages I should look for to diagnose the issue? If not, what else might I try short of a complete wipe and restore, which may well just restore whatever glitch is causing the issue anyway?

(If it was my own laptop, at this point I'd probably just admit defeat and do a clean install, and reinstall and set up every app as I needed it... but that's really not an option with my wife's.)

Update 2022-05-08: Following suggestions below, I've now weeded out as much old cruft as I can using EtreCheck, reinstalled Monterey, and tried a different power brick. The problem is still happening, and I can still find no trace in the logs of what is causing the freeze.

1 Answer 1

2

Given the age of the machine (and possibly because of the cloning method used): I agree that it's much more likely to be a software issue than hardware.

First of all, I would get a Full installer of Monterey 12.3 and install it. By default, this will not wipe the apps and data, but may install something necessary for the M1 that wasn't on the Intel clone source.

I would also download and run EtreCheck. This will give you a detailed report on the state of the Mac's software: third-party Launch Agents, kernel extensions, etc. You can then easily identify anything that needs either removing or updating.

At worst, I would erase the disk, install the OS, and then migrate or restore apps, data and settings from your wife's backup. Manual reinstallation should only be necessary for a few complex apps.

EDIT: But if you've tried all that and the problem persists, then I would take it to an Apple Store.

2
  • Thanks! Reinstalling Monterey over the top was probably next on my list, hadn't considered EtreCheck though. Will try that too.
    – calum_b
    Commented Mar 18, 2022 at 10:13
  • Fwiw, I've now weeded out as much old cruft as I can using EtreCheck, reinstalled Monterey, tried a different power brick, and the problem is still happening.
    – calum_b
    Commented May 8, 2022 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .