2

I'm using "passwords" to store some of my access data but today I've noticed that Safari saves every site there even if I clicked "never for this website". After visiting 100-200 sites with webforms, where I don't need to save passwords, I have my "passwords" app full of useless entries.

How can I make Safari not store any webform AT ALL, so I will put necessary data by hand and use it on demand?

1
  • As a guess, it sounds like these entries it's saving are perhaps just to remember that you selected "never for this site"? Or are you actually seeing form data included in the entries it's creating? (if so, that would be a bug to report)
    – Dave
    Mar 13 at 0:31

1 Answer 1

3
  1. Open the Safari
  2. Click "Safari" in the menu bar and then click Preferences…
  3. Click on the AutoFill tab and then Uncheck the option for User Names and Passwords

After this, Safari will no longer offer to save your passwords.

1
  • "After this, Safari will no longer offer to save your passwords."- Yep, but it also no longer offer me to autocomplete webforms i need. So as far as i understand it is not possible to keep autocomplete on but disable every webform from saving ? Mar 13 at 15:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .