4

I use iMac (27-inch, Late 2012) running on Catalina 10.15.7 (19H1715). Just bought a new Apple Magic Keyboard with Touch ID. The problem I have is that NONE of the buttons inside the red rectangle (see photo) work. The result is that I cannot increase/decrease brightness; skip songs; increase/decrease volumes, etc. I did not have this problem on my old magic keyboard.

Does anyone have any solutions, please?

Hardware Overview:

  • Model Name: iMac
  • Model Identifier: iMac 13,2
  • Processor Name: Quad-Core Intel Core i7
  • Processor Speed: 3.4 GHz
  • Number of Processors: 1
  • Total Number of Cores: 4
  • L2 Cache (per Core): 256 KB
  • L3 Cache: 8 MB
  • Hyper-Threading Technology: Enabled
  • Memory: 32 GB
  • Boot ROM Version: 425.0.0.0.0

enter image description here

2
  • 1
    there is no photo attached. Commented Mar 12, 2022 at 0:02
  • Look at System Prefs > Keyboard > "Use F1, F2 etc as standard function keys"
    – Tetsujin
    Commented Mar 12, 2022 at 7:02

3 Answers 3

2

In case you haven't thought of it, go into System Preferences > Keyboard with the keyboard attached and make sure Use F1, F2, etc. keys as standard function keys is not checked. If this is the problem, then holding the Fn (bottom-left) and F12 would work to increase the volume but not F12 by itself.

macOS keeps these settings on a per-keyboard basis, so perhaps somehow it got toggled for the new keyboard you connected.

1

I had a similar problem with the magic keyboard 2 on iMac (late 2013) High Sierra 10.13.6. It is as though these buttons do not exist and are not recognised. The only thing that worked was installing Karabiner-Elements app. https://karabiner-elements.pqrs.org/ You can download the version that corresponds to your operating system. Karabiner-Elements: Select correct version for download

1

The only think that worked for me was forgetting the keyboard in bluetooth settings, and pairing it again. Worked like a charm.

1
  • Simple as that, yeah. Commented Jun 20, 2023 at 12:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .